Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26535

Names are included with published submission

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.3
    • Component/s: Workshop
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Names and photos are included with published submmission even though the setting is not to allow students to view names.

        Gliffy Diagrams

          Attachments

            Activity

            mudrd8mz David Mudrák added a comment -

            Confirmed. The current code always shows the names because Workshop 1.x used to do that in the League table, too. I am going to introduce new capability "View published submissions' authors names" to control that. The default value would be "Allow" for Teachers and Students but you will be able to override it. Thanks for the report!

            mudrd8mz David Mudrák added a comment -

            A patch that adds the new capability has been submitted for the integration.

            tsala Helen Foster added a comment -

            Vernellia, thanks for your report and David, thanks for fixing it.

            The new capability mod/workshop:viewauthorpublished is available in the latest 2.0.2+.

            http://docs.moodle.org/en/Capabilities/mod/workshop:viewauthorpublished


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11