Moodle
  1. Moodle
  2. MDL-26626

Hard coded string in block Course completion status

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2, 2.1, 2.2
    • Fix Version/s: 2.0.4, 2.1.1
    • Component/s: Blocks
    • Labels:
      None

      Description

      The course completion status appears to have an hard coded string. To reproduce in Moodle 2.0.2 (Build: 20110221):

      • create a course with two or more activities with completion criteria
      • on the course completion settings, select two or more activities to complete the course
      • now add a Course completion status block on course home page
      • the block shows, among the other things, "Activities completed 0 of X"
      • now switch to a language different from English
      • string "Activities completed" changes, but "0 of X" is still displayed in English

        Gliffy Diagrams

          Issue Links

            Activity

            Dan Poltawski added a comment -

            Thanks, i've come up with a fix which i'm submitting for integration

            Sam Hemelryk added a comment -

            Thanks Dan,
            This has been integrated now.
            It was merged to master and cherry-picked to MOODLE_21_STABLE and MOODLE_20_STABLE.

            Cheers
            Sam

            Andrew Davis added a comment -

            Passing. In future please add testing instructions that can be performed by someone who may not be familiar with the specific code area

            In this case I wound up wasting a bunch of time because the course completion block shows something entirely different to teachers Vs students. You need to be logged in as a teacher to set this up but then you need to log in as a student to see the modified string.

            Thanks for the fix

            Eloy Lafuente (stronk7) added a comment -

            Incorporated upstream, thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: