Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26685

Each attempt builds on last seems to be broken with Essays

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: Questions, Quiz
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      From http://moodle.org/mod/forum/discuss.php?d=170181:

      Quiz is Essay Question type with 3 of this types in one quiz. The Quiz is set to Unlimted amount of attempts.

      Student takes a QUIZ and submits for marking

      Teacher Marks Quiz, tells the student you have missed some bits out or got parts of the quiz wrong.

      Student then creates a second attempt and no answers appear in the quiz for him to adapt. All they get is blank essay boxes.

      The students have to open up attempt 1 review copy and paste their previous answers into attempt two and then correct their answers.

        Gliffy Diagrams

          Attachments

            Activity

            moodlecvqo CLAIRE BROWNE added a comment -

            This bug also effects Moodle 1.9

            timhunt Tim Hunt added a comment -

            I can't reproduce this in Moodle 1.9.11.

            I did find a problem in Moodle 2.x, which I have solved. With this change, Moodle 2.0 is working for me.

            mudrd8mz David Mudrák added a comment -

            This has been integrated and tested for the next 2.0+. Thanks for the report and for the fix. Claire, please report a separate issue for 1.9 if you find a way how to reproduce it there.

            moodlecvqo CLAIRE BROWNE added a comment -

            Hello Tim,

            Sorry for the delay.

            The answers now come across in the next attempt.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11