Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26697

mediaplugin fixes and improvements META

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: Filters, Resource
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      This is a meta issue for all mediaplugin and resource media embedding problems:
      1/ finish conversion to flowplayer - outdated version, incorrectly imported, hacky integration, old players have license issues
      2/ fix media sizes and resizing from url - there were incorrect CSS sizes and size hints from URL did not work
      3/ more iOS compatibility - mp3 and youtube especially
      4/ remove old eolas workaround and media players - not necessary in current browsers
      5/ move image embedding to filter_urltolink - this new image support in mediafilter was intended to allow entering of image urls in FORMAT_MOODLE, unfortunately it was eating all image links
      6/ improve regex matching
      7/ switch hack player colors to use real CSS - OUTPUT must not be used from filters due to caching issues
      8/ sync embedding code in mediafilter and resources

        Gliffy Diagrams

          Issue Links

          1.
          Problems in Moodle 2.0 mediaplugin filter... Sub-task Closed Petr Skoda
           
          2.
          Can't change the video size for flv Sub-task Closed Petr Skoda
           
          3.
          flv filter (flowplayer) expands the videos to large size regardless of original size Sub-task Closed Petr Skoda
           
          4.
          Replace Flash multimedia filter with Open Source player Sub-task Closed Petr Skoda
           
          5.
          FLV player should be moved to lib, upgraded and calling code standardised Sub-task Closed Petr Skoda
           
          6.
          Multimedia filter should be able to create embeds that don't include a download link Sub-task Closed Petr Skoda
           
          7.
          UFO for SWF is deprecated, update to swfobject Sub-task Closed Petr Skoda
           
          8.
          mp3player.swf does not play MP3 files in IE6, with flash 10 Sub-task Closed Petr Skoda
           
          9.
          problem when more than 15 mp3 player embed on single Web page Sub-task Closed Petr Skoda
           
          10.
          Small MP3 player is only visible for the last "audio file" link Sub-task Closed Petr Skoda
           
          11.
          YouTube filter - "wmode" makes player inaccessible to keyboard users Sub-task Closed Petr Skoda
           
          12.
          Extend mediaplugin to convert links to images into normal embedded images Sub-task Closed Petr Skoda
           
          13.
          Allow larger sizes for multimedia filters (flv, swf, etc.) Sub-task Closed Petr Skoda
           
          14.
          flash player customization not working with course themes Sub-task Closed Petr Skoda
           
          15.
          invalid context fallback in format_text() Sub-task Closed Petr Skoda
           
          16.
          Change SWF filtering in mediaplugin to work in trusted texts only Sub-task Closed Petr Skoda
           
          17.
          Flash video doesn't always display on page - Requires page refresh Sub-task Closed Petr Skoda
           
          18.
          mp3s do not play in Moodle with latest versions of Flash installed Sub-task Closed Petr Skoda
           
          19.
          Flash filter is not resizable when using "Link to File or Website." Sub-task Closed Petr Skoda
           
          20.
          filtering doesn't work when nothing between <a ...> and </a> tag Sub-task Closed Petr Skoda
           

            Activity

            skodak Petr Skoda added a comment -
            jonathan Jonathan Harker added a comment - - edited

            Just a suggestion so don't shoot me, but perhaps much of this would be easier if instead of regex hunting HTML tag soup for the href attributes of <A> tags, we could hunt for a pseudo-tag, wiki markup, or markdown syntax, or something instead, e.g.

            {{media | http://www.youtube.com/watch?v=I4U6T_BB1N8}}
            {media=http://www.youtube.com/watch?v=I4U6T_BB1N8}

            Then 1. it would be easy to extend TinyMCE or $editordujour to do media links, 2. the regex would be simpler and more robust, 3. it would be easier to extend to newer formats, and 4. it would be more explicit (no accidental embedded stuff when links were intended, etc)

            skodak Petr Skoda added a comment -

            I personally never liked the "hunting in HTML tag soup", it should be very easy to create a new filter for this in 2.0, unfortunately the TinyMCE is not pluggable enough yet, hopefully 2.1 will solve the remaining editor and text format issues.

            skodak Petr Skoda added a comment -

            I have nearly finished this little task, the code is at https://github.com/skodak/moodle/commits/wip_MDL-26697_20_media
            Later today I am going to upload a backup of test course with all media types and some more comments.

            skodak Petr Skoda added a comment -

            Subtasks to be closed if it lands in main git repo...

            derekcx Derek Chirnside added a comment -

            Cool.
            OK, what now? I've visited https://github.com/skodak/moodle/commits/wip_MDL-26697_20_media there doesn't seem to ba any place I can read any detail on what you have done . . . Is there a test site or it it basically download the patch and install it somewhere?
            Or does someone now QA the thing? "if it lands in the main git repo" How can we help it land in the right place?

            -Derek

            derekcx Derek Chirnside added a comment -

            I will ask one other question here:
            Filters. What about filters for a bunch of other sites, eg vimeo, slideshare, blip TV, ?
            Are filters easy to write?
            How do these relate to Moodle media. Do they hook into the media player fo do they use their own ot does it depend?

            -Derek

            skodak Petr Skoda added a comment - - edited

            Hello,
            1/ you can get a zip package from https://github.com/skodak/moodle/tree/w11_MDL-26697_20_media (Click on the "Download" button).
            2/ vimeo is there already, if you want to add more of these you could copy/paste/tweak the vimeo code that can be found in filter/mediaplugin/filter.php

            The next steps will be code review and testing, if all goes well and no problems are found it will be available in the next weekly build which is a snapshot of the stable git branch. In any case the more people help with testing the better.

            Petr


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11