Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26796

stop accepting arrays in required_param() and optional_param()

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.2
    • Component/s: General
    • Labels:

      Description

      This is a old hack, I should have protested when this was proposed. This can interfere with our DB layer and other parts of moodle, it may create random errors...
      Solution is to add one more optional parameter or different functions.

      We can not forbid it in stable because some parts rely on it...

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              skodak Petr Skoda
              Reporter:
              skodak Petr Skoda
              Integrator:
              Eloy Lafuente (stronk7)
              Tester:
              Rajesh Taneja
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                5/Dec/11