Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26845

Will need to use SSL (https) when connecting to Google API's

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Libraries, Portfolio
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Google have announced that all calls to some of their API's (inc DocsList) must use SSL as from 15/11/2011.

      Code in lib/googleapi.php uses http, not https as will be required from this date.

      See:
      http://googlecode.blogspot.com/2011/03/improving-security-of-google-apis-with.html

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              poltawski Dan Poltawski
              Reporter:
              jp76 Jason Platts
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: