Again, this is something I need in the question engine code.
I need to rewrite the draft file URLs in the student's response before the files are actually saved to the database. (Becuase if the response has not changed, we don't save it - and you can only test whether the response has changed after you remove the draft area id.)
Therefore, I want to separate out the bit at the end of file_save_draft_area_files to be a separate function. Of course, file_save_draft_area_files will call the new function, so that the behaviour does not change.
I also think it is just nicer to put this specific bit of processing into a separate function.