Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3410

HotPot module does not use german strings

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Inactive
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Moodle 2.0.2+ (20110313) and latest HotPot

      $module->version = 2010080321;
      $module->release = 'v3.0.21';
      $module->requires = 2010080300; // Requires this Moodle version
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Hi,

      I 'm translating also the strings in the Hot Potatoes module but I can't see them on my test server.
      The new Hot Potatoes module is installed in Moodle 2.0.2 and it is working but I do not get the german strings.
      Could it be that the translated strings in AMOS are not connected with the new module. I hope you will help.

      David answered the last question in the AMOS translation forum
      > Hi Ralf,
      > that sounds like a bug in Moodle then (and be related to yet another issue that was mentioned recently in Moodle developers chat).
      > The de.zip language pack contains hotpot.php correctly. Let me look at this, I'll let you know.

      The attached three images are showing the problem.
      You see the Website administration > Plugins > Activities > HotPotatoes settings in picture hotpot1.png

      (1) Choosing the language packs de, de_du, or de_kids I always get the same results.
      (2) The menus and the blocks are shown in german language.
      (3) The strings in the HotPotatoes settings are in english language.

      Next I open the settings when I at a new HotPotatoes activity to a courses. See hotpot2.png

      (1) The language setting is still one of the german packs de_kids.
      (2) The menus and the blocks are shown in german language.
      (4)(5) The HotPotatoes strings are in english language.

      At last I show you the translated strings in AMOS

      (6) I hope that this hotpot is the correct component.
      (7) Found german strings are 175 and no string is missing.
      (8) This is the array of german strings.

      Do you know what would be wrong?

      Ralf

        Attachments

        1. hotpot1.png
          hotpot1.png
          363 kB
        2. hotpot2.png
          hotpot2.png
          402 kB
        3. hotpot3.png
          hotpot3.png
          245 kB

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: