Moodle
  1. Moodle
  2. MDL-26902

Add a "Cancel" button and string to the Private Files area to make it clearer that saving is required.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.3
    • Component/s: Files API, Repositories
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE

      Description

      Lots of users are confused and run into problems that an uploaded file is not save in an privat file area until 'save changes' is clicked.

      Why is this required?
      Can this be done directly while uploading?

      The additional step to save the upload is unexpected and so not user friendly.

        Gliffy Diagrams

          Issue Links

            Activity

            Petr Skoda added a comment -

            All other places use two step file upload, also the internals are not designed to allow direct manipulation.

            This may be changed in the future, but it would require a lot of new code...

            Ralf Hilgenstock added a comment -

            Attaching a file to an activity is a one step process. The main problem is that confirmation of upload is unexpected. I tried to change the page design by adding a text line and moving the buttons to give the users more direction.

            Petr Skoda added a comment -

            It is a two step process - first edit activity, then hit save changes button. If you press cancel in any form with file picker, file manager or html editor all file changes are canceled.

            Ralf Hilgenstock added a comment -

            Yes technically, but perception is different. People publish the post by saving and its clear that they have to do this. The attachment is included then.

            Its not logical that an uploaded file has to be confirmed again after succesfull upload. The user sees the file in the folder with all the other files and there is no visual difference between old (confirmed) and new unconfirmed files. I've seen it now by different users that this is a real problem.

            Do you think we can make the little changes as suggested very quickly. Its only a new lang string and a new placement for existing buttons. No functional changes are required.

            Petr Skoda added a comment - - edited

            the problem is the changes would have to be big, I agree with you it would be great if this could be improved in 2.1 together with all other filepicker related issues.

            Ralf Hilgenstock added a comment -

            Petr,
            my suggestion for a first optimization (adding a text and moving two buttons) can't be a big change, but a first and helpfull change

            Charles Fulton added a comment -

            Is this obsolete in light of MDL-31315?

            Dan Poltawski added a comment -

            I think so, closing as this has been resolved from a user POV by MDL-31315.


              People

              • Votes:
                9 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: