Moodle
  1. Moodle
  2. MDL-26974

SCORM - add Moodle logging for opening individual SCO

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2, 2.2, 2.3
    • Fix Version/s: 2.2.1
    • Component/s: SCORM
    • Labels:
    • Environment:
      Linux Debian 2.6.32-5-amd64
    • Database:
      PostgreSQL
    • Testing Instructions:

      With debugging level set lower than developer,
      Enter a SCORM package and launch any of the SCO's in the package - Check the live logs:
      /report/loglive/index.php

      Check to see if "launch" actions for each sco with the path to the sco in the details field are listed - previously these actions were only shown when developer level set.

      Show
      With debugging level set lower than developer, Enter a SCORM package and launch any of the SCO's in the package - Check the live logs: /report/loglive/index.php Check to see if "launch" actions for each sco with the path to the sco in the details field are listed - previously these actions were only shown when developer level set.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      master_MDL-26974

      Description

      mdl_log table doesn't save the "launch" action for SCORM module.
      An example is if we want to see the report log live. We can see when an user enter in a SCORM, but in previous versions we could know when a user changed to section (in SCORM), but now this detail isn't. That's due to now in the database the "launch" action refered to SCORM isn't saved.

        Gliffy Diagrams

          Activity

          Dan Marsden added a comment -

          Hi,

          the launch action is only used when debugging is turned on - perhaps you should be looking for the action "view"?

          Paco A added a comment -

          Hi,

          ¡thanks very much for the idea! I've done a system for estimate (around) the dedicated time by the students. I use data from mdl_log_table and I need to know "launch" actions about SCORM. That's because if I only use "view" action and a student exceed time limit into a SCORM, and then if the student close the browser witouth close session or doesn't clic in another section, that time won't be able to be considered.

          With your suggestion I must estimate time in SCORMs (with another table dedicated to SCORMs) and add it to estimated time from mdl_log_table. And doesn't consider time SCORM if after, in the same session, the user has done clic in another Moodle section.

          Dan Marsden added a comment -

          I'll think about this - calculating time spent in SCORM objects should really use cmi.core.session_time - not rely on Moodle log entries, but this does rely on your SCORM object setting this data correctly.

          Changing this from "bug" to "improvement" as this is not a bug but a feature request.

          Paco A added a comment -

          Ok. At the moment I'll estimate session time through subtractions with any action, the next action and time out. If after "view" action and "scorm" module there's any different to "login" action, then I'll take into account the spent time. Obviously students always must close their sessions or click in another moodle place —outside SCORM— if they want their spent time will be kept in mind.

          Thanks for your ideas.

          Dan Marsden added a comment -

          just looked at this again and decided this would be quite useful information in a lot of different situations with buggy packages, general use by students complaining they "completed" the SCORM but no data was passed back to Moodle due to JS issues etc.

          NOTE TO INTEGRATOR: Master only.

          thanks!

          Aparup Banerjee added a comment -

          for 2.2.x and master?

          Dan Marsden added a comment -

          Fine by me - thanks

          Aparup Banerjee added a comment -

          cool, improvement integrated, up for testing.

          Ankit Agarwal added a comment -

          Working Great,
          Thanks for fixing this!

          Eloy Lafuente (stronk7) added a comment -

          Yes, you did it!

          Now your code is part of the best weeklies released ever, many thanks!

          Closing, ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: