Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.1
    • Component/s: General
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE

      Description

      Already done:

      • new git MOODLE_20_STABLE branch in all repos
      • updated git sync scripts
      • add new master branch in PULL project

      We need to:

      • bump release version.php
      • change maturity level
      • update environment.xml in all branches

      Other changes in infrastructure:

      • amos branch tracking
      • page with downloads

      Next:

      • keep version the same with 2.0 for one week to allow switching of branches

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            skodak Petr Skoda added a comment -

            The PHP requirement was selected to be 5.3.2 because it is the version available in RHEL 6, latest Debian has more recent version. I do not know what 5.3.3 was recommended in 2.0.x, I did not find any critical bug fixed in 5.3.2. In any case it is strongly recommended to use latest version from http://php.net

            Show
            skodak Petr Skoda added a comment - The PHP requirement was selected to be 5.3.2 because it is the version available in RHEL 6, latest Debian has more recent version. I do not know what 5.3.3 was recommended in 2.0.x, I did not find any critical bug fixed in 5.3.2. In any case it is strongly recommended to use latest version from http://php.net
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            The 3 pull requests have been integrated:

            Note1: http://docs.moodle.org/en/admin/environment/php has been edited to add the new information.

            Note2: MDL-27005 has been created about to delete some (outdated) contents from all the 19, 20 and master environment.xml files.

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - The 3 pull requests have been integrated: Note1: http://docs.moodle.org/en/admin/environment/php has been edited to add the new information. Note2: MDL-27005 has been created about to delete some (outdated) contents from all the 19, 20 and master environment.xml files.
            Hide
            tsala Helen Foster added a comment -

            Thanks Petr

            Show
            tsala Helen Foster added a comment - Thanks Petr
            Hide
            ashleyholman Ashley Holman added a comment -

            Can someone please let me know whether Moodle 2.1 will run on PHP 5.2.10? Are there any extra features used from 5.3.2, or was it just a performance recommendation?

            Thanks

            Show
            ashleyholman Ashley Holman added a comment - Can someone please let me know whether Moodle 2.1 will run on PHP 5.2.10? Are there any extra features used from 5.3.2, or was it just a performance recommendation? Thanks
            Hide
            ashleyholman Ashley Holman added a comment -

            I've answered my above question now. Tried 2.1 with PHP 5.2.10 and got a parse error in the question engine. Looks like it's making use of PHP 5.3's late static binding feature.

            Show
            ashleyholman Ashley Holman added a comment - I've answered my above question now. Tried 2.1 with PHP 5.2.10 and got a parse error in the question engine. Looks like it's making use of PHP 5.3's late static binding feature.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  1/Jul/11