Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26986

Correct answers incorrectly revealed when students can review responses but not marks/feedback

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      When the "Review options" are set to allow students to view "Responses" they should not be able to determine the correct answer for any question. The "Quiz navigation" block shows correct answers in green and incorrect answers in red (at least in FormFactor) revealing correct answers. This could compromise a test that many students are taking at the same time.

      The issue is especially serious since leaving all "Review options" unchecked results in a server error on quiz submission.

        Gliffy Diagrams

          Activity

          timhunt Tim Hunt added a comment -

          This has been fixed since Moodle 2.1 was released. Closing.


            People

            • Votes:
              10 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: