Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27032

XLS export of logs is printing incorrectly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.2
    • Fix Version/s: STABLE backlog
    • Component/s: Administration
    • Labels:
    • Environment:
      MAMP
    • Database:
      MySQL
    • URL:
      /course/report/log/index.php?id=1
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      While looking into MDL-27031 I found that the xls downloads for reports were printing incorrectly. I searched for an existing ticket but could not find one.

      Steps to reproduce:
      1) Navigate to Site Admin -> Reports -> Logs
      2) Change the 6th dropdown to 'Download in Excel Format' and select the 'Get these logs' button.
      3) Open the xml file and find bad / missing data.

        Gliffy Diagrams

          Activity

          blepoxp Glenn Ansley created issue -
          blepoxp Glenn Ansley added a comment -

          Attached xls to ticket.

          blepoxp Glenn Ansley made changes -
          Field Original Value New Value
          Attachment logs_20110330-0956.xls [ 23431 ]
          tsala Helen Foster added a comment -

          Glenn, thanks for your report. Increasing priority and hoping that this issue can be fixed soon.

          tsala Helen Foster made changes -
          Labels triaged
          Assignee Martin Dougiamas [ dougiamas ] moodle.com [ moodle.com ]
          Fix Version/s STABLE backlog [ 10463 ]
          Priority Minor [ 4 ] Critical [ 2 ]
          Component/s Administration [ 10050 ]
          Component/s Other [ 10063 ]
          blepoxp Glenn Ansley added a comment -

          Helen,
          I spent some time looking at this today but have to stop. I got as far as determining that the $str variable (which holds the data that's missing in the downloaded file) gets lost somewhere inside the t3lib_cs::conv() method. Specifically in my case, I'm losing it when it gets passed through the iconv() function on line 631 of lib/typo3/class.t3lib_cs.php

          This is new territory for me as far as the moodle script and the iconv function. I have a suspicion that this isn't the source of the problem though. If I bypass that function and try to just return the original $str (with its correct value) the script still fails to deliver what I'd expect.

          I'll come back to this later this week, but maybe someone else with some more insight will see this in the meantime

          nikhilgupta0901 Nikhil Gupta added a comment -

          Hi Glenn,
          I didnt find the problem in the downloaded xls file,it seems to be perfect one ,no data is missing.Can you explain it little bit more why the problem and when its occuring..

          dougiamas Martin Dougiamas made changes -
          Workflow MDL Workflow [ 69001 ] MDL Full Workflow [ 76251 ]
          ankit_frenz Ankit Agarwal made changes -
          Fix Version/s STABLE Sprint 22 [ 12156 ]
          Assignee moodle.com [ moodle.com ] Ankit Agarwal [ ankit_frenz ]
          ankit_frenz Ankit Agarwal made changes -
          Status Open [ 1 ] Development in progress [ 3 ]
          ankit_frenz Ankit Agarwal added a comment -

          Hi Glenn,
          I cannot reproduce this issue either. If it was a problem, seems to be fixed to me.
          Can you please confirm if this is still an issue for you or not, so that I can close it.

          Thanks

          blepoxp Glenn Ansley added a comment -

          Looks to be working. Thanks!

          blepoxp Glenn Ansley made changes -
          Status Development in progress [ 3 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Fix Version/s STABLE Sprint 22 [ 12156 ]
          Subversion JIRA

          Links Hierarchy

           Documentation

          Invalid license: EXPIRED

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: