Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27107

Profile field "confirmed" set to 0 for incoming roaming users

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.2, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: MNet
    • Labels:
    • Testing Instructions:

      Needs two Moodle 2.x sites networked via MNet, one (A) acting as identity provider, one (B) as service provider.

      1. Login as admin at the identity provider site (A)
      2. At the Peers settings page for the second site, make sure the field "confirmed" is not selected among "Fields to export" (you may need to uncheck "Use the default settings instead")
      3. Still at (A), log in as a user who has not roamed to the second site yet (eg create a fresh new user)
      4. Roam to the site (B)
      5. Log out and log in as admin at (B)
      6. Filter all users with "confirmed" set to "no"
      7. TEST: make sure the new remote user is not listed here (hence is confirmed)

      Show
      Needs two Moodle 2.x sites networked via MNet, one (A) acting as identity provider, one (B) as service provider. 1. Login as admin at the identity provider site (A) 2. At the Peers settings page for the second site, make sure the field "confirmed" is not selected among "Fields to export" (you may need to uncheck "Use the default settings instead") 3. Still at (A), log in as a user who has not roamed to the second site yet (eg create a fresh new user) 4. Roam to the site (B) 5. Log out and log in as admin at (B) 6. Filter all users with "confirmed" set to "no" 7. TEST: make sure the new remote user is not listed here (hence is confirmed)
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-27107-mnet-confirmed

      Description

      It may happen that the profile field "confirmed" is set to 0 for incoming roaming users. It leads to removal of the records. See http://moodle.org/mod/forum/discuss.php?d=171512 for the full report. Due to this data-loss risk, triaged as Critical

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mudrd8mz David Mudrák added a comment -

              Submitting patch for integration.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated thanks!

              Side note: It surprised me a bit to see the "auth" column in both lists, when it's set to "mnet". FYC, ciao

              samhemelryk Sam Hemelryk added a comment -

              Tested. Passed. Thanks

              stronk7 Eloy Lafuente (stronk7) added a comment -

              git & cvs repositories have been populated with this solution. Many thanks for your collaboration, yay!

              Closing, ciao

              dmonllao David Monllaó added a comment -

                People

                • Votes:
                  4 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Oct/11