Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27121

CLI upgrade on moodle_20_stable branch requires php 5.3

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: Administration
    • Labels:
      None
    • Environment:
      Debian Linux x86_64, Mysql 5, Apache2
    • Database:
      MySQL
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      When upgrading 2.0 sites to latest weekly build - Moodle 2.0.2+ (Build: 20110406) - using CLI upgrade, upgrade fails with the following messasge:

      !! php !!
      Required minimum version: 5.3.2. Version in use: 5.2.17.0.0

      AFAIK, PHP 5.3 is required for Moodle 2.1, thus php 5.3 check appears to be wrong when upgrading 2.0 sites in the same branch.

      Logging in as Administrator and performing an interactive web based upgarde, upgrade completes correctly and site is working.

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            andreabix Andrea Bicciolo added a comment -

            According to Petr suggestion, we tested using codebase from github: 2.0.2-375. The issue is present also in this repo.

            Show
            andreabix Andrea Bicciolo added a comment - According to Petr suggestion, we tested using codebase from github: 2.0.2-375. The issue is present also in this repo.
            Hide
            skodak Petr Skoda added a comment -

            This issue will be fixed in the next weekly, thanks for the report.

            Petr

            Show
            skodak Petr Skoda added a comment - This issue will be fixed in the next weekly, thanks for the report. Petr
            Hide
            andreabix Andrea Bicciolo added a comment -

            Thanks for fixing Petr. Just a note, the bug affects the CLI installer too, I suppose the fix resolve both upgrade and istall process.

            Show
            andreabix Andrea Bicciolo added a comment - Thanks for fixing Petr. Just a note, the bug affects the CLI installer too, I suppose the fix resolve both upgrade and istall process.
            Hide
            skodak Petr Skoda added a comment -

            yes, both should be fixed, thanks again

            Show
            skodak Petr Skoda added a comment - yes, both should be fixed, thanks again

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11