Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27121

CLI upgrade on moodle_20_stable branch requires php 5.3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: Administration
    • Labels:
      None
    • Environment:
      Debian Linux x86_64, Mysql 5, Apache2
    • Database:
      MySQL
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      When upgrading 2.0 sites to latest weekly build - Moodle 2.0.2+ (Build: 20110406) - using CLI upgrade, upgrade fails with the following messasge:

      !! php !!
      Required minimum version: 5.3.2. Version in use: 5.2.17.0.0

      AFAIK, PHP 5.3 is required for Moodle 2.1, thus php 5.3 check appears to be wrong when upgrading 2.0 sites in the same branch.

      Logging in as Administrator and performing an interactive web based upgarde, upgrade completes correctly and site is working.

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            andreabix Andrea Bicciolo
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              5/May/11