Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27194

Problem with database upgrading from 1.9.11 to 2.0.2+ (Build: 20110406) (2011033002.01)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
    • Environment:
      server cent0S 5.5
      mysql 5.1.56 INNODB engine
      php 5.3.6
    • Database:
      MySQL
    • URL:
      euromet-ext2.enm.meteo.fr/courses
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Impossible to upgrade from 1.9.x to 2.02
      database and all tables using utf8_unicode_ci

      Error message :
      Debug info: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '='
      SELECT DISTINCT c.id AS courseid, ra.enrol, c.timecreated, c.timemodified
      FROM mdl_course c
      JOIN mdl_context ctx ON (ctx.instanceid = c.id AND ctx.contextlevel = 50)
      JOIN mdl_role_assignments ra ON (ra.contextid = ctx.id AND ra.enrol <> '')
      LEFT JOIN mdl_enrol e ON (e.courseid = c.id AND e.enrol = ra.enrol)
      WHERE c.id <> ? AND e.id IS NULL
      [array (
      0 => '1',
      )]
      Stack trace:

      • line 391 of /lib/dml/moodle_database.php: dml_read_exception thrown
      • line 749 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
      • line 4084 of /lib/db/upgrade.php: call to mysqli_native_moodle_database->get_recordset_sql()
      • line 1382 of /lib/upgradelib.php: call to xmldb_main_upgrade()
      • line 273 of /admin/index.php: call to upgrade_core()

        Gliffy Diagrams

          Activity

          vicent Vincent Terol created issue -
          skodak Petr Skoda added a comment -

          Hello, this is a problem in your server configuration, Moodle does not set collation in mysql - something must have changed in your server, this happens when you restore your mysql db dump on different or upgraded server.

          Please search moodle.org forums for more info, thanks.

          skodak Petr Skoda made changes -
          Field Original Value New Value
          Status Open [ 1 ] Ready for review [ 10010 ]
          Assignee moodle.com [ moodle.com ] Petr Škoda (skodak) [ skodak ]
          Resolution Not a bug [ 7 ]
          skodak Petr Skoda made changes -
          Status Ready for review [ 10010 ] Closed [ 6 ]
          dougiamas Martin Dougiamas made changes -
          Workflow MDL Workflow [ 69297 ] MDL Full Workflow [ 96388 ]
          Subversion JIRA

          Links Hierarchy

           Documentation

          Invalid license: EXPIRED

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: