Moodle
  1. Moodle
  2. MDL-27209

Medium priority accessibility problems in Moodle 2

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Accessibility
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      16851

      Description

      These have not been marked as high priority, but they still require attention, so I'm listing them here for completeness.

      1. In FF various non-link items receive keyboard focus but they shouldn't because they are not links: label module instances (these each have two tab stops). Recommendation: ensure non-link items do not receive keyboard focus.

      2. On Calendar block there is invisible tab stop between 'skip calendar' link and the month link. There is also invisible tab stop between month link and current date link. Recommendation: ensure focus is visible, or remove focusable items.

      3. The Navigation block comes after the main content in the tab order. Recommendation: tab order should follow visual/logical order.

      4. 'Your progress' tickboxes: when operate these with the keyboard, the focus returns to the top of the page. The same issue applies for screenreader users. Recommendation: if possible enable focus to remain on the button. (Another one for you Sam?)

      5. Link icon is labelled "URL" which may not be meaningful for screenreader users. Recommendation: change this to "link" or "web page" or similar.

      6. A URL resource item is read as "bullet link graphic URL link getting started URL" which seems unnecessarily long. This is due to 'URL' being repeated and there being two separate links. The same repetition occurs on the other items. Recommendations: remove the repetition of URL (and similar labels) and if possible remove one of the links. Perhaps the two links can be combined into one? (Note - I'm not sure what Chetz means by two links here, as the html clearly only has one).

      7. The 'hide' block buttons are announced as graphics, but not as links so a screenreader user would not know they could interact with it is a button. Recommendation: enable this to be announced as a link or a button so users know they can interact with it.

      8 Resource icons: in OU-Moodle 1.9 there was clever programming to indicate icon types without repeating the name of the item, e.g. if the link to a forum was 'activity forum' the forum icon label would not be included, but if the link was 'café' then the 'forum' icon label would be included. Recommendation: this function should be instated in standard Moodle.

      9 File icon: this has the alt 'file' but this does not indicate the type of the file and this could be significant information for screenreader users. Recommendation: change this to indicate the type of file, e.g. PDF, Word etc.

        Issue Links

          Activity

          Jenny Gray added a comment -

          Further information on item 6 (and related item 8). The HTML that jaws is reading is

          <li class="activity url modtype_url" id="module-16"><div class="mod-indent"><a onclick="window.location.href ='http://jmg324.vledev2.open.ac.uk/demo/mod/url/view.php?id=16&redirect=1';return false;" href="http://jmg324.vledev2.open.ac.uk/demo/mod/url/view.php?id=16"><img src="http://jmg324.vledev2.open.ac.uk/demo/theme/image.php?theme=ou&image=f%2Fweb&rev=223" class="activityicon" alt="URL" /> <span class="instancename">Getting started<span class="accesshide " > URL</span></span></a>

          The duplication of "URL" is caused by the accesshide bit at the end. Suggestion - don't bother doing the accesshide bit at all. This will also resolve issue 8 as there will be no duplication of "forum forum".

          The issue of the duplicated "link" text would appear to be a bug in jaws.

          Sam Marshall added a comment -

          note: I have changed this bug into its own issue because it didn't seem appropriate to have 'medium-priority accessibility problems' as a subtask of 'high-priority accessibility problems'. Also now it can have subtasks of its own (although I'm not volunteering to create subtasks for all 9 existing issues, maybe people can create subtasks for those if they start work on them).

          Jenny Gray added a comment -

          A few more "medium" concerns found by our accessibility testers, mostly to do with the flexible_table class:

          Table content should be left aligned for both row and heading content. Table rows should be separated by grid lines to make them easier to follow.

          Where the table has sortable columns, keyboard focus should return to the table after altering the sort order.

          Where the table has sortable columns, improve the screenreader text so there is a pause between reading the column name and "Sort..."

          Where the table has sortable columns, remove the sort action from the column heading and include a separate button to trigger sort - which would resolve the issue above as well!

          Where the table has sortable columns, remove the alt text from the sort order icon and use a title instead.

          Chetz Colwell added a comment -

          I've been looking at some of the issues here and am adding a few comments in the hope that some of these things can be completed.

          Some issues seem to have been resolved on The Open University’s VLE (OU VLE), but I’m not sure if this means they are fixed elsewhere and I couldn’t always find another example in the demo site. If you can give me links to places where I can test them then I will do that.

          Re item 1: this related to the Navigation block. Seems to be fixed on OU VLE. However, I had a different problem which I think is reported here: MDL-30897.

          Re item 2: this seems to be resolved on http://school.demo.moodle.net/ - can this be ticked off?

          Re item 3: - seems to be resolved in OU VLE. Is it still an issue elsewhere?

          Re item 4: - seems to be resolved in OU VLE. Is it still an issue elsewhere?

          Re item 5: this is still an issue: ‘URL’ is not meaningful for many users. Even if users know this is a web page, how is it distinguished from ‘page’ and ‘subpage’ resouces? It seems that screenreader users are possibly the only users who are aware of these labels, but are also the users who most need this indication to be meaningful.
          I suggest that at least ‘URL’ be changed to ‘web page’.

          Re item 6: What I mean by two links is that JAWS is saying ‘link’ twice (see the quote in the original list above) – maybe this is one link for the icon and one for the text link? – I’m not sure. Here is a snippet from OU VLE:
          “<li class="activity subpage modtype_subpage" id="module-142861"><div class="mod-indent"><div class="deco-cr"></div><a href="https://learn2.open.ac.uk/mod/subpage/view.php?id=142861"><img src="https://learn2.open.ac.uk/theme/image.php/ou/subpage/1358844206/icon" class="activityicon" alt="Subpage" /> <span class="instancename">Elluminate discussions<span class="accesshide " > Subpage</span></span></a></div></li>”

          I support Jenny’s suggestion above but would suggest that the image and alt text be placed after the text link (this is based on a plea from a screenreader user to be able to use the screenreader function of navigating by the initial letter of the text link, e.g. ‘e’ for Elluminate, which is not currently possible).
          Can this change be taken forward now?

          Re items 7, 8 and 9: These are still issues.

          Re Jenny’s list relating to tables: as far as I know these are still issues.
          Can something be done to take this forward?

          I hope this is useful and I will endeavour to respond to any queries.
          Chetz

          Michael de Raadt added a comment -

          Hi, Chetz and all.

          Thanks for reviewing this issue.

          It looks like some work has been done on the issue, but to take it forward from here, more sub-tasks need to be created for the remaining tasks. This can be done by using the More Actions menu and choosing "Create sub-task".

          In relation to Jenny's item 5, I don't think we should change URL to something else. The term "web page" would be incorrect as a URL can lead to any type of file. As the resource type name is URL, I believe this should remain as-is. It seems that the duplication of alt and title has been removed from the URL resource and other activities/resources, so it should not be reading URL twice now. The resource/activity icon and link are combined in one anchor tag.

          Point 8 has been re-added. I'm not sure if it was ever missing. It was added in MDL-7436 and I can't find anywhere it might have been removed since then. The functionality remains.

          Point 9 is being worked on in MDL-37054. As that issue is already a sub-task of another META issue, I will just link it to this issue.

          By my reckoning, that leaves only point 7 remaining. This is partially being dealt with in MDL-35832, but not completely.

          Michael de Raadt added a comment -

          Looking at the remaining issues identified earlier, it looks like this issue is now complete.


            People

            • Votes:
              3 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: