Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27212

Tag page shows Courses, Blogs and Users anchor links even if the anchor is not present

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.2, 2.2.2
    • Fix Version/s: 2.3
    • Component/s: Tags
    • Labels:
    • Testing Instructions:
      Hide
      1. Goto site pages>tags
      2. add around 5-6 tags
      3. Create a few blog entries and tag them with varies tags
      4. Create a few courses and tag them with varies tags
      5. Tag a few user with various tags (can be done from the edit profile page)
      6. Now search for each tag and check the results.
      7. Make sure you see the links to "user,blogs,courses" only when those results exist. For example say a tag "xyz" is used only with blogs and courses but not users, so you should be able to only blogs and course link on the top
      Show
      Goto site pages>tags add around 5-6 tags Create a few blog entries and tag them with varies tags Create a few courses and tag them with varies tags Tag a few user with various tags (can be done from the edit profile page) Now search for each tag and check the results. Make sure you see the links to "user,blogs,courses" only when those results exist. For example say a tag "xyz" is used only with blogs and courses but not users, so you should be able to only blogs and course link on the top
    • URL:
      tag/search.php
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      MDL-27212-master

      Description

      In the Tags page the 'relatedpages' line contains the links <a href=""> to html anchors <a name =""> for Courses, Blogs and Users.

      These anchors are created lateron during the creation of the page and may not even be present.
      If for example no Courses or Blogs are 'tagged' only the list of Users with that tag are shown.

      The link to the Courses and Blogs anchor is still shown even though they are not present.

      Also; if just one anchor is present, the link to it will be displayed right above it, making it moot.

      To see this issue, go to
      tag/search.php
      select a tag that does not have Courses, Blogs and/or Users

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Jun/12