Moodle
  1. Moodle
  2. MDL-27282

Regression: expanded icon link is broken, no expanded icons are displayed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      nginx (Moodle slash argument setting => disabled) - postgres 9 - firefox 4 - theme extended from arialist
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      16974

      Description

      Since I upgraded my site today Firebug displays the following error for the /my/index.php:

      Image corrupt or truncated: https://custom.com/custom/theme/image.php?theme=custom&image=t%2Fexpanded&rev=202

      Note that https://custom.com/custom/theme/image.php?theme=custom&image=t/expanded&rev=202 does display the image.

      It seems that some '%2F' <=> '/' conversion broke the expanded icon.

      Error:

      INFO get: inserting before: firstthemesheet :: yui_co...ebug.js (line 70)
      ERROR Image corrupt or truncated: https://custom.com/custom/theme/image.php?theme=custom&image=t%2Fexpanded&rev=202
      INFO loader: attempting to load core_dock, https://custom.com/custom/lib/yui/3.2.0/build/ :: yui_co...ebug.js (line 70)
      

        Activity

        Hide
        Jérôme Mouneyrac added a comment -

        It got fixed once I purged all caches.

        I don't close this issue because tt could cause a problem for sites that don't like to purge caches (like Moodle.org ) ... if they have this issue.

        Show
        Jérôme Mouneyrac added a comment - It got fixed once I purged all caches. I don't close this issue because tt could cause a problem for sites that don't like to purge caches (like Moodle.org ) ... if they have this issue.
        Hide
        Michael de Raadt added a comment -

        Thanks for reporting this issue.

        We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

        If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

        Michael d.

        TW9vZGxlDQo=

        Show
        Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
        Hide
        Michael de Raadt added a comment -

        I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

        This is being done as part of a bulk annual clean-up of issues.

        If you still believe this is an issue in supported versions, please create a new issue.

        Show
        Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: