Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Blog
    • Labels:
    • Rank:
      17034

      Description

      Moodle.org blog entries have disappeared completely.
      Now all blog entires have gone to site entries with userids apparently, but what did you do with the prior blog entries, and was there something published about losing these that I missed, am I the only one caught unawares?

        Issue Links

          Activity

          Hide
          Marc Grober added a comment -

          Not sure whether they are related as far as the source of the problem, but as far as result, it appears that personal blogs have disappeared (again)

          Show
          Marc Grober added a comment - Not sure whether they are related as far as the source of the problem, but as far as result, it appears that personal blogs have disappeared (again)
          Hide
          Mary Cooch added a comment -

          Just confirming this - I only posted a couple of blog entries in my early days here but when I checked they have completely vanished and all I have is my external blog entries. Are they gone for good then? Should I have known?

          Show
          Mary Cooch added a comment - Just confirming this - I only posted a couple of blog entries in my early days here but when I checked they have completely vanished and all I have is my external blog entries. Are they gone for good then? Should I have known?
          Hide
          Marc Grober added a comment -

          I have upgraded the severity on this as it appears to be rather more widespread than expected and there appears to be no no involvement from HQ

          Show
          Marc Grober added a comment - I have upgraded the severity on this as it appears to be rather more widespread than expected and there appears to be no no involvement from HQ
          Hide
          Marc Grober added a comment -

          I have upgraded the severity on this as it appears to be rather more widespread than expected and there appears to be no no involvement from HQ

          Show
          Marc Grober added a comment - I have upgraded the severity on this as it appears to be rather more widespread than expected and there appears to be no no involvement from HQ
          Hide
          Helen Foster added a comment -

          I've no idea why blog entries on moodle.org have disappeared - it wasn't intentional! Changing the issue type from MDLSITE to MDL as I imagine moodle.org is not the only site affected.

          Show
          Helen Foster added a comment - I've no idea why blog entries on moodle.org have disappeared - it wasn't intentional! Changing the issue type from MDLSITE to MDL as I imagine moodle.org is not the only site affected.
          Hide
          Marc Grober added a comment -

          Soooooooo.......... nothing has been done on either the potential system problem or as to restoring the materials that was deleted over the past three months?

          Show
          Marc Grober added a comment - Soooooooo.......... nothing has been done on either the potential system problem or as to restoring the materials that was deleted over the past three months?
          Hide
          Aparup Banerjee added a comment -

          Just picking this up now

          Show
          Aparup Banerjee added a comment - Just picking this up now
          Hide
          moodle.com added a comment - - edited

          If there's a MDL bug in the blogs upgrade please fix it, Apu.

          As for moodle.org, there's some doubt if keeping blog active there is worthwhile doing given our resources. See MDLSITE-782.

          – Martin

          Show
          moodle.com added a comment - - edited If there's a MDL bug in the blogs upgrade please fix it, Apu. As for moodle.org, there's some doubt if keeping blog active there is worthwhile doing given our resources. See MDLSITE-782 . – Martin
          Hide
          Aparup Banerjee added a comment -

          ok, I've done upgrade (1.9->2.0) tests, linked to various timeframes of entries in external blogs and scrutinized blog_sync_external_entries().

          The post deletion really does seem to delete only posts (within the returned rss data timeframe, older posts are ignored) that are deleted from the external blog feed.

          I can't replicate this in my moodle instance and I think this bit is working fine within moodle so i'm going to close this as cannot replicate.

          Thanks for reporting the issue.

          Show
          Aparup Banerjee added a comment - ok, I've done upgrade (1.9->2.0) tests, linked to various timeframes of entries in external blogs and scrutinized blog_sync_external_entries(). The post deletion really does seem to delete only posts (within the returned rss data timeframe, older posts are ignored) that are deleted from the external blog feed. I can't replicate this in my moodle instance and I think this bit is working fine within moodle so i'm going to close this as cannot replicate. Thanks for reporting the issue.

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: