Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27461

Moodle doesn't like RSS feeds generated by Database activity module

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 2.0.2, 2.0.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Moodle 2.0.2+ (Build: 20110427)
      php 5.3.3
      MySQL 5.5.9
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      When trying to add the feed URL of a Database activity module to the RSS feeds within Moodle (i.e. to a Remote news feed block), I get this error:

      Error loading this RSS feed (cURL Error: couldn't connect to host)

      The feed URL I am trying to add is:

      http://vle.c.fun.ac.jp/moodle/rss/file.php/22172/9ab6e723dfd4b448ee729b73971a74ce/mod_data/92/rss.xml

      Inputting this directly into Firefox or Safari works fine. Other feeds added to Moodle (e.g. BBC feeds) work as expected.

        Gliffy Diagrams

          Attachments

            Activity

            blepoxp Glenn Ansley added a comment -

            Hi Peter,
            The only way I could reproduce this was when I accidentally placed the Title of the Feed where the URL goes. Is it possible that you did the same thing?

            stuart Peter Ruthven-Stuart added a comment -

            Hello Glenn,
            Thanks for your comment. I have re-confirmed this error on my Moodle system, and attached a screenshot as 'proof'. I definitely pasted the feed url into the correct text box.

            poltawski Dan Poltawski added a comment -

            Hi Peter,

            This isssue is caused because Moodle does not seem to be able to connect to itself - the curl connect error means moodle can't connect to the url given. Is it possible that a firewall or proxy is causing this issue?

            thanks,
            dan

            poltawski Dan Poltawski added a comment -

            Hi Peter,

            I've tested this on my installation and I can add your rss feed. Like I say there is some problem affecting Moodle connecting to itself.

            Perhaps you need to specify a http proxy?


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: