Moodle
  1. Moodle
  2. MDL-27576

Alternative Grader Report "Column Width" settings do not work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Component/s: Gradebook
    • Labels:
      None
    • Database:
      MySQL
    • Testing Instructions:

      Changed settings in site level (Admin panel>Grades>Report Settings>Alternative Grader Report) to 0,blank,2, 15, 100 and none of them made any difference to the column width.

      Changed the settings in the course level (Site>Course>Grades>My Preferences>Alternative Grader Report), your options are - 0 = auto width, empty = site default. setting either one with the various combos listed above at the site level, made no change at all. Each time it looked like it was set to auto widith, as the columns were not a universal size.

      Tested on three different client sites.

      Show
      Changed settings in site level (Admin panel>Grades>Report Settings>Alternative Grader Report) to 0,blank,2, 15, 100 and none of them made any difference to the column width. Changed the settings in the course level (Site>Course>Grades>My Preferences>Alternative Grader Report), your options are - 0 = auto width, empty = site default. setting either one with the various combos listed above at the site level, made no change at all. Each time it looked like it was set to auto widith, as the columns were not a universal size. Tested on three different client sites.
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      17236

      Description

      When changing the column width settings at either the site level or the report level it does not change the column width, not matter what options you select.

      "Column Width" - by default, is set to 0 (noted as default width) at the site level (Admin panel>Grades>Report Settings>Alternative Grader Report), Changing this is supposed to allow you to adjust the width of all columns in the Alternative Grader Report.

      Also, which makes it confusing, at the course level (Site>Course>Grades>My Preferences>Alternative Grader Report), your options are - 0 = auto width, empty = site default. Setting the option to auto width should make some columns wider to accommodate longer activity names when needed, but any combination of the column width settings at the site and course Alternative Grader Report level looks like it is always set to auto.

        Activity

        Mark Nielsen added a comment -

        Apparently this is not a core issue. Thanks!


          People

          • Votes:
            5 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: