Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27742

Error when trying to create a backup of a course in master

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      While trying to backup a course in up to date master with default settings I get the following error:

      error/baseelementincorrectfinalorattribute

      Stacktrace:

      • line 125 of /backup/util/structure/base_final_element.class.php: base_element_struct_exception thrown
      • line 251 of /backup/util/structure/backup_nested_element.class.php: call to base_final_element->find_element_by_path()
      • line 237 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->find_element()
      • line 231 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->convert_sql_params()
      • line 127 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->convert_table_params()
      • line 131 of /mod/forum/backup/moodle2/backup_forum_stepslib.php: call to backup_nested_element->set_source_table()
      • line 86 of /backup/util/plan/backup_structure_step.class.php: call to backup_forum_activity_structure_step->define_structure()
      • line 153 of /backup/util/plan/base_task.class.php: call to backup_structure_step->execute()
      • line 178 of /backup/moodle2/backup_activity_task.class.php: call to base_task->execute()
      • line 148 of /backup/util/plan/base_plan.class.php: call to backup_activity_task->execute()
      • line 105 of /backup/util/plan/backup_plan.class.php: call to base_plan->execute()
      • line 293 of /backup/controller/backup_controller.class.php: call to backup_plan->execute()
      • line 111 of /backup/util/ui/backup_ui.class.php: call to backup_controller->execute_plan()
      • line 87 of /backup/backup.php: call to backup_ui->execute()

      I first thought it may be the forum module, however I attempted a backup without forums and got the following stacktrace:

      • line 125 of /backup/util/structure/base_final_element.class.php: base_element_struct_exception thrown
      • line 251 of /backup/util/structure/backup_nested_element.class.php: call to base_final_element->find_element_by_path()
      • line 237 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->find_element()
      • line 231 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->convert_sql_params()
      • line 127 of /backup/util/structure/backup_nested_element.class.php: call to backup_nested_element->convert_table_params()
      • line 107 of /mod/glossary/backup/moodle2/backup_glossary_stepslib.php: call to backup_nested_element->set_source_table()
      • line 86 of /backup/util/plan/backup_structure_step.class.php: call to backup_glossary_activity_structure_step->define_structure()
      • line 153 of /backup/util/plan/base_task.class.php: call to backup_structure_step->execute()
      • line 178 of /backup/moodle2/backup_activity_task.class.php: call to base_task->execute()
      • line 148 of /backup/util/plan/base_plan.class.php: call to backup_activity_task->execute()
      • line 105 of /backup/util/plan/backup_plan.class.php: call to base_plan->execute()
      • line 293 of /backup/controller/backup_controller.class.php: call to backup_plan->execute()
      • line 111 of /backup/util/ui/backup_ui.class.php: call to backup_controller->execute_plan()
      • line 87 of /backup/backup.php: call to backup_ui->execute()

      If I turn off user data, and/or activities so that they aren't to be included the backup complete's successfully.

      Cheers
      Sam

        Gliffy Diagrams

          Issue Links

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Detected as regression caused by 2b04c41c (MDL-27471). We need to wrap the literal params into sql_param() helper.

            Ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Closing this as duplicate of MDL-27820

            Thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: