Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27904

In Choice module 'Publish full results' displays results horizontally even if vertical is picked

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Choice
    • Labels:
    • Environment:
    • Testing Instructions:

      Create Choice with:
      display mode: Display vertically
      Publish results: Show results to students after they answer
      Privacy of results: Publish full results, showing names and their choices

      Have at least one user answer the choice
      Have teacher view results

      Show
      Create Choice with: display mode: Display vertically Publish results: Show results to students after they answer Privacy of results: Publish full results, showing names and their choices Have at least one user answer the choice Have teacher view results
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      There is a bug with 'Publish full results'. The results display horizontally even if vertical is picked and these errors show up:
      Invalid get_string() identifier: 'withselected' or component 'quiz'

      • line 5910 of /lib/moodlelib.php: call to debugging()
      • line 6500 of /lib/moodlelib.php: call to core_string_manager->get_string()
      • line 215 of /mod/choice/renderer.php: call to get_string()
      • line 105 of /mod/choice/renderer.php: call to mod_choice_renderer->display_publish_name_vertical()
      • line 168 of /mod/choice/view.php: call to mod_choice_renderer->display_result()

        Gliffy Diagrams

          Issue Links

            Activity

            danmarsden Dan Marsden added a comment -

            thanks for the report - will take a look this week.

            moodle.com moodle.com added a comment -

            Hi, Dan.

            As this is related to a QA test it needs attention. If you would like us to look at this, please let is know.

            Michael;

            danmarsden Dan Marsden added a comment -

            hard to define this as a failed test... it looks like expected behaviour to me.

            Display mode has only historically been for the display of the choice options - not the results themselves. (unless Rosie changed something in her recent changes that I missed)

            It might make sense to change this so that display mode also affects the results - but this would be a new feature request unrelated to a QA test.

            danmarsden Dan Marsden added a comment -

            confirming and closing this as not a bug - display mode is only for the display of the options - not for the result set.

            If you think this should change feel free to create a new feature request for it.

            thanks!

            dougiamas Martin Dougiamas added a comment -

            Added link to bug about missing string

            danmarsden Dan Marsden added a comment -

            ah - now I remember - there is a vertical display for Anon results only - however this is only for the student view - teachers/admins can see the full results including names which is only available in horizontal form.

            rwijaya Rossiani Wijaya added a comment -

            Dan is correct.

            The vertical/horizontal display for choices and results are only available for students view. Privacy results can only be display in horizontal view.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: