Moodle
  1. Moodle
  2. MDL-27914

Students can't view images in entries with 'view single' for 'image gallery' preset

    Details

    • Rank:
      17559

      Description

      Students can't view images in entries for 'image gallery' preset when viewing single is chosen. Student can see thumbnail of image when view list is chosen. Teacher can see images in both.

      1. login as a student on http://qa.moodle.net/
      2. Go to the Moodle Features Demo class
      3. Go to the Image gallery Database module in Topic 4 (http://qa.moodle.net/mod/data/view.php?id=17)
      4. add entry with image
      5. choose view single
      6. The image should appear

        Issue Links

          Activity

          Hide
          Michael Spall added a comment -

          Possibly related to this issue fixed earlier.

          Show
          Michael Spall added a comment - Possibly related to this issue fixed earlier.
          Hide
          Anthony Borrow added a comment -

          Michael - I just tried the steps you provided and I was not able to reproduce an issue. As student I was able to upload an image and then see it in single and list views. Peace - Anthony

          Show
          Anthony Borrow added a comment - Michael - I just tried the steps you provided and I was not able to reproduce an issue. As student I was able to upload an image and then see it in single and list views. Peace - Anthony
          Hide
          Anthony Borrow added a comment -

          This seems to be more browser specific. Students cannot view single entry with Chrome but it works fine on FF. Michael Blake noted that if we remove the 100% height then the image appears and suggested moving that code out to CSS which seems like a good idea. Peace - Anthony

          Show
          Anthony Borrow added a comment - This seems to be more browser specific. Students cannot view single entry with Chrome but it works fine on FF. Michael Blake noted that if we remove the 100% height then the image appears and suggested moving that code out to CSS which seems like a good idea. Peace - Anthony
          Hide
          Michael de Raadt added a comment -

          I also test this on IE9 and it seems to work.

          Michael (d, not B).

          Show
          Michael de Raadt added a comment - I also test this on IE9 and it seems to work. Michael (d, not B).
          Hide
          Michael de Raadt added a comment -

          The user doesn't seem to matter here, just the browser.

          Show
          Michael de Raadt added a comment - The user doesn't seem to matter here, just the browser.
          Hide
          Aparup Banerjee added a comment -

          this seems to be a problem with the preset at mod/data/preset/imagegallery/csstemplate.css

          the css can be changed within the template presets (doing that) however changing existing/modified css templates would be risky/difficult.

          the css can also be changed at the css template editor tab.

          Show
          Aparup Banerjee added a comment - this seems to be a problem with the preset at mod/data/preset/imagegallery/csstemplate.css the css can be changed within the template presets (doing that) however changing existing/modified css templates would be risky/difficult. the css can also be changed at the css template editor tab.
          Hide
          Aparup Banerjee added a comment -

          This fix fixes the image gallery CSS templates only. (any instantiated copies won't be fixed)

          If your image gallery is broken, you can apply the fix here to your template or else you could reset your instance of image gallery CSS under template tab -> CSS template

          The fix basically adds 'img' as a descendant to #singleimage and also sets height to auto.

          Show
          Aparup Banerjee added a comment - This fix fixes the image gallery CSS templates only. (any instantiated copies won't be fixed) If your image gallery is broken, you can apply the fix here to your template or else you could reset your instance of image gallery CSS under template tab -> CSS template The fix basically adds 'img' as a descendant to #singleimage and also sets height to auto.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated, thanks!
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Passing test without further action. This will be tested by MDLQA-962 once this meets upstream.

          Show
          Eloy Lafuente (stronk7) added a comment - Passing test without further action. This will be tested by MDLQA-962 once this meets upstream.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          All git & cvs servers have been updated with these cool changes, so closing, many thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - All git & cvs servers have been updated with these cool changes, so closing, many thanks!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: