Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27940

The parents on an active node on the navigation arn't expanded by default.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: Navigation
    • Labels:
      None

      Description

      There is a bug in the navigation presently that is leading the branches containing the current page to stay closed rather than opening by default to show it.
      I had a quick look at the CSS and the active node is marked so its just the parents - likely a code problem in the navigation preventing the active node informing its parents when its found to be active.

        Gliffy Diagrams

          Issue Links

            Activity

            samhemelryk Sam Hemelryk added a comment -

            Interesting wee problem.
            Recent changes to the way in which navigation nodes are created has led to them being created without a parent being provided. This problem arises that when a navigation_node is constructed it checks itself to find out if it is active and if it is it marks itself active and then informs its parent.
            Because no parent is provided during construction now this doesn't happen, the node is marked active but the parent isn't informed when it is added.

            Will work on a solution to this now.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            lol, along the last days I found this happening here and there (specially noticeble because I had to expand before going to participants page to log as someone else).

            But didn't realise it was a bug but a improvement, lol. Nice you have worked it back!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Just guessing if we should have one MDLQA for the expected behavior of the navigation block on well-know pages (front, category, course, activity/view ...).

            Ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Confirmed, now courses and activities expand ok, thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Your awesome code is now part of the next Moodle release, congrats!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  1/Jul/11