Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-27951

Incorrect output in scorm->results tab if there are not attempts

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      check the Reports page of a SCORM that has no attempts - there's a delete attempts link on the page if needed - make sure blocks and footer are displayed correctly.

      Show
      check the Reports page of a SCORM that has no attempts - there's a delete attempts link on the page if needed - make sure blocks and footer are displayed correctly.
    • Workaround:

      (dont use the results tab before having attempts, lol)

      Show
      (dont use the results tab before having attempts, lol)
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      MDL27951

      Description

      I was testing MDL-27366 when, after deleting all the existing attempts in one SCORM activity (results tab), I got the visualization completely messed (see screenshot).

      When the page had attempts it looked ok, so far.

      Ciao

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              danmarsden Dan Marsden added a comment -

              adding Ankit to this - can you please make sure this is resolved in your new version of this page? - thanks!

              ankit_frenz Ankit Agarwal added a comment -

              Hi dan,
              I will make sure this is resolved in the new version!!
              Thanks

              salvetore Michael de Raadt added a comment -

              Sounds like a good experience for Ankit.

              I've set the Fix version for this as Stable backlog, but please work on this as you see fit.

              If you think the priority should be increased, please let me know.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Only master?

              danmarsden Dan Marsden added a comment -

              yes - only affects master - was caused by a previous patch that went into master only - thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (master only). Thanks!

              nebgor Aparup Banerjee added a comment -

              Works for me on master as i'm testing master this is passed.
              btw, tested on 2.1 on integration and it does look messed up to me.. please check.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Closing, this is now part of Moodle. Big thanks!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/Dec/11