Moodle
  1. Moodle
  2. MDL-27969

Error when doing random assignment of submissions in Workshop with Moodle 2.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.3, 2.1
    • Fix Version/s: 2.0.4
    • Component/s: Workshop
    • Labels:
    • Testing Instructions:

      See the linked MDLQA. This patch should fix the PHP notices thrown in situations like:

      • manually allocated reviewer without own submission kept during the random allocation that does not include reviewers without the submission
      • removed the student role from a user that is already allocated as a reviewer or reviewee and trying to re-allocate submissions randomly, keeping the current allocations
      Show
      See the linked MDLQA. This patch should fix the PHP notices thrown in situations like: manually allocated reviewer without own submission kept during the random allocation that does not include reviewers without the submission removed the student role from a user that is already allocated as a reviewer or reviewee and trying to re-allocate submissions randomly, keeping the current allocations
    • Workaround:

      Ignore the error message and/or don't type the Save Changes button after allocations are complete. The assignments seem to have been made okay even though this error message is generated.

      Show
      Ignore the error message and/or don't type the Save Changes button after allocations are complete. The assignments seem to have been made okay even though this error message is generated.
    • URL:
      qa.moodle.net
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-27969-randomallocator
    • Rank:
      17611

      Description

      This issue arose while doing QA Test MDLQA-1041.

      I get the following error message when doing a random assignment of submissions when using the Workshop in Moodle 2.1:

      ( ! ) Notice: Undefined offset: 9 in /html/mod/workshop/allocation/random/lib.php on line 124
      Call Stack

      Time Memory Function Location
      1 0.0002 690544

      {main}( ) ../allocation.php:0
      2 0.1748 41606496 workshop_random_allocator->init( ) ../allocation.php:53

      ( ! ) Notice: Undefined offset: 10 in /html/mod/workshop/allocation/random/lib.php on line 124
      Call Stack
      # Time Memory Function Location
      1 0.0002 690544 {main}

      ( ) ../allocation.php:0
      2 0.1748 41606496 workshop_random_allocator->init( ) ../allocation.php:53
      ( ! ) Notice: Undefined offset: 11 in /html/mod/workshop/allocation/random/lib.php on line 124
      Call Stack

      Time Memory Function Location
      1 0.0002 690544

      {main}

      ( ) ../allocation.php:0
      2 0.1748 41606496 workshop_random_allocator->init( ) ../allocation.php:53

      This occurred when I typed Save Changes after selecting Random allocation. This may be a problem of not understanding exactly what I was supposed to do at this point. Perhaps this was trying to allocate the assessments a second time. This part of the workshop is kind of confusing to me. I would have expected to see a Continue button rather than Save Changes.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Promoting this issue as it is related to a QA test.

          David Mudrak added a comment -

          Confirmed, I can reproduce the issue:

          1. using the manual allocator, choose a reviewer without own submission and let him/her to assess a submission
          2. using the random allocator, let it allocate one submission per reviewer having the "Participants can assess without having submitted anything"

          The allocator tries to inform about the re-used manual allocation but the name of the reviewer is not available in the list of reviewers because he/she does has not submitted anything.

          David Mudrak added a comment -

          Patches for 2.0 and 2.1 submitted for integration

          Eloy Lafuente (stronk7) added a comment -

          Looks perfect, integrated, thanks!

          Eloy Lafuente (stronk7) added a comment -

          Passing test without further action. This will be tested by MDLQA-1041 once this meets upstream.

          Eloy Lafuente (stronk7) added a comment -

          All git & cvs servers have been updated with these cool changes, so closing, many thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: