Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28028

It is possible for old garbage data in the database to break the upgrade to 2.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      Create a 1.9 or 2.0 site. Create a quiz and some quiz attempts.

      Go into the database and delete some rows from quiz_attempts, without deleting the linked data in other tables.

      Upgrade to 2.1 and check it works.

      Show
      Create a 1.9 or 2.0 site. Create a quiz and some quiz attempts. Go into the database and delete some rows from quiz_attempts, without deleting the linked data in other tables. Upgrade to 2.1 and check it works.
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      See the comments in MDL-27929.

      Old data in the database, that should have been deleted long ago, is breaking the upgrade.

      We need to add a step that cleans up the garbage before the main upgrade runs.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                timhunt Tim Hunt
                Reporter:
                timhunt Tim Hunt
                Integrator:
                Eloy Lafuente (stronk7)
                Tester:
                Glenn Ansley
                Participants:
                Component watchers:
                Tim Hunt, Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
              • Votes:
                2 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  1/Jul/11