Moodle
  1. Moodle
  2. MDL-28029

Content package error in IMS content package resource

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.3, 2.1
    • Fix Version/s: None
    • Component/s: IMS-CP resource type
    • Labels:
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Rank:
      17660

      Description

      An IMS package resource can be added to a course without error, but when it is accessed, the error "Content package error!" is shown.
      Editing the resource leads to "no packed file has been uploaded".

      The IMS package is OK

      • The same IMS file was uploaded and executed in the same site and course as a SCORM Package.
      • The same IMS file was uploaded and executed in Moodle 1.9 without problems as an IMS Package.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put it on our backlog and we'll try to get to it as soon as we can.

          In the meantime adding more information, such as screenshots, sample files, replication instructions, fix test instructions, a workaround or even a code solution, will help us and other users.

          Chris Mattia added a comment -

          Taking the same IMS package that I used for lynda.com Moodle Essential Training for Teachers, I attempted to use the IMS Package tool in Moodle 2.1. The first time you attempt to link to the zip file it looks like the link is made, but when you save and Display you get an error message of 'Content package error!'. If you return back to the course and then attempt to Edit the IMS resource you just created you see a note saying No file attached. If you attempt to re-add the same package, after clicking Save File from the file picker you get a message saying 'undefined'. if you immediately attempt to add the same file again you get a warning that the file is already attached and do you want to rename the new file. Renaming or copying over both give the same 'undefined' response on the page and the Save and Display page still gives the same Content package error! message.

          I'm currently recording the Moodle 2.1 EssT for Teachers and would love to include this feature if anyone can offer any help that would be fantastic!

          Dirk Meyer added a comment -

          Just checking on the status of this. We really need to have this going in our 2.1. We get the same behavior as Chris describes above.

          Eloy Lafuente (stronk7) added a comment -

          Hi,

          I'm closing this as duplicate of MDL-29145, that has been integrated some minutes ago, will be tested along the next 24h and will be published everywhere (git/cvs/downloads) along the week.

          Once updated, feel free to reopen this if necessary, but really looks like a dupe.

          Thanks and ciao


            People

            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: