Moodle
  1. Moodle
  2. MDL-28056

Question bank contents will not display when a question has an image in its question text

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.3
    • Fix Version/s: None
    • Component/s: Questions, Quiz
    • Labels:
    • Environment:
      windows server 2003, IIS6, FastCGI,
    • Database:
      MySQL
    • Testing Instructions:

      1. setup a question bank with images in the question.
      2. create a quiz
      3. edit quiz
      4. Click on "show" link under question bank contents
      5. Select the category of the question bank with the questions with images

      Once you select a category the question bank will not load. The browser (IE, Chrome, Firefox) will say that it is waiting for the server. After about 5 to 10 mins I get a HTTP error 500.

      This question bank has about 192 questions in it, but this problem will happen even if there is a small number of questions in the question bank, such as 12. Once I remove the images from the question bank it will load the question bank and allow me to add questions to the quiz.

      Show
      1. setup a question bank with images in the question. 2. create a quiz 3. edit quiz 4. Click on "show" link under question bank contents 5. Select the category of the question bank with the questions with images Once you select a category the question bank will not load. The browser (IE, Chrome, Firefox) will say that it is waiting for the server. After about 5 to 10 mins I get a HTTP error 500. This question bank has about 192 questions in it, but this problem will happen even if there is a small number of questions in the question bank, such as 12. Once I remove the images from the question bank it will load the question bank and allow me to add questions to the quiz.
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      17678

      Description

      I'm finding when trying to add a group of random question using the question bank content menu it is unable to load question banks with images in them. Once I take out the images the question banks load in the question bank content menu.

        Activity

        Tim Hunt added a comment -

        I have no idea what you are trying to say. Please write proper steps to reproduce as on http://docs.moodle.org/dev/Using_Tracker#How_to_write_a_good_Tracker_entry

        Jason Shelvy added a comment -

        I have added the testing instruction hopefully it will help you understand the problem

        Jason Shelvy added a comment -

        I waned to post a video that may help explain the issue. http://screencast.com/t/Qwb9Pq2VN

        Aparup Banerjee added a comment -

        just saw the video, seems the 'add question from question bank to quiz' list loading via ajax is ajax-broken when the list/question contains an image.

        Tim Hunt added a comment -

        Thanks, the steps you pout in the testing instructions are exactly what was needed to make this clear.

        Vickie Frohne added a comment -

        I just experienced this issue for the first time since our upgrade from 1.9.5 to 2.0.3. I have a large question bank (300 questions) for a science class, and many questions contain images. Fortunately, the old questions that were created before the upgrade are OK. The issue only appeared when I created two new questions, with images, in 2.0.3. Removing the images from the two offending questions allowed the question bank to operate normally. Both of these were "description" questions. I have not yet tried reproducing this with other question types.

        To reproduce: In 2.0.3, add a "description" question containing a .gif or .jpg image to a large question bank. Create/edit Quiz. Questions that are visible in the question bank can be added to the quiz. Any action that would change the view of questions (selecting a category to view, choosing a different page to view, reordering the list of questions, in an attempt to find questions) initiates a long server reload (several minutes) and loss of functionality. It is sometimes necessary to exit Moodle completely and close the browser before being able to re-enter the question bank and edit the offending questions.Removing the images from the new questions cures the problem.

        Tim Hunt added a comment -

        I have just been trying to reproduce this on my system, and I cannot make it happen. I am using 2.0.4+, but just to be sure, I tried 2.0.3 and that version also worked.

        I don't understand what might be happening to cause these symptoms. It is just displaying a list of questions, and whether the question text contains an image or not should not make any significant difference. Since I can't make this happen on my computer, where I can poke around to work out what is going on, I don't know what I can do here.

        Frédéric Massart added a comment -

        Sprint planning.
        Estimated development difficulty: XS (to investigate), M (to fix)

        Tim Hunt added a comment -

        Hopefully this is just a case of test, then close as cannot-reproduce.

        Frédéric Massart added a comment -

        Closing this issue as I can't reproduce it. It has most certainly been fixed in an earlier version. If you are still experiencing this problem, please reopen an issue. Thank you!


          People

          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: