Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: Filters
    • Labels:
      None
    • Testing Instructions:

      1. Enable multimedia plugins. (admin settings -> plugins -> filters -> manage filters)
      2. Multimedia plugins settings, enable 'HTML 5 audio'.
      3. On course page, add a label, add aac file through moodle media button (texteditor's option)

      make sure there is no error message to disallow adding aac file.

      Show
      1. Enable multimedia plugins. (admin settings -> plugins -> filters -> manage filters) 2. Multimedia plugins settings, enable 'HTML 5 audio'. 3. On course page, add a label, add aac file through moodle media button (texteditor's option) make sure there is no error message to disallow adding aac file.
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      add Support to upload aac file through filepicker.

        Gliffy Diagrams

        1. aac_test.aac
          1.63 MB
          Rossiani Wijaya

          Issue Links

            Activity

            Rossiani Wijaya added a comment -

            attache sample of aac file

            Rajesh Taneja added a comment -

            Hi! Rosie,

            It looks Great to me

            Rossiani Wijaya added a comment -

            Thanks for reviewing Raj.

            Submitting for integration.

            Kathy Cannon added a comment -

            Just a quick MINOR mention re the HTML5 Audio description in Site Admin > Plugins > Filters > Multimedia. There seems to be a misspelling of AAC as it is called "ACC". Thanks for the help here! Looking forward to the update to accept AAC format through the HTML editor.

            Eloy Lafuente (stronk7) added a comment -

            Sorry, I'm rejecting this because:

            1) The changes in file_types.mm are BIG making it impossible to diff. This can be fixed by a) using old map app and same xml format or b) Specify what has changed. Also I hope new format won't break anything.
            2) I don't get why one change in the filepicker causes any change in the mediaplugin filter. And, more yet, I don't understand those changes (but the ACC => AAC ones).
            3) The issue is lacking testing instructions.

            Ciao

            Rossiani Wijaya added a comment -

            Hi Eloy,

            1) I fixed the file_types.mm by applying the previous version of the file and add aac node to web audio.
            2) Currently, most browsers can't support aac/mp4 file, but it needed to support the mobile application. So to prevent the browser to display a non-working player, a link is provided for user to have access to the file.
            3) I will write a proper testing instruction right after I post this message.

            Eloy Lafuente (stronk7) added a comment -

            Pasting from MOBILE-46 to have everything here too:

            sorry, I've no problems about getting the mm file updated to support AAC or whatever.

            But the change in the filter is not acceptable at all. It simply and suddenly drops support for playing AAC/MP4 files in the browser. I can imagine a lot of sites using AAC/MP4 (the same than WEBM or whatever and we are not explicitly dropping support for it). Nor for Flash.

            So, talking about MDL-28061, the filepicker part is ok, but the filter part needs to be handled apart, surely not causing complete drop of support ever but some alternative solution (link or whatever).

            It's crazy we continue supporting realaudio reproduction (no OS/browser supports them) and you want to drop AAC/MP4 reproduction, when it's possible to get them working under all OSs and browsers via plugins.

            Ciao

            Rossiani Wijaya added a comment -

            After conversing with Eloy, we decided to split the issue.

            This issue will fix the mm file to support AAC file.

            I will create a new tracker to discuss aac/mp4 filter.

            update patch.

            Rossiani Wijaya added a comment -

            Get free ticket to directly submitting this to integration.
            Thanks Eloy

            Eloy Lafuente (stronk7) added a comment -

            integrated, thanks!

            Helen Foster added a comment -

            Tested as described. There was no error message, however the sample aac file wouldn't play (using chrome on ubuntu).

            Eloy Lafuente (stronk7) added a comment -

            Yay, this is now part of the just released Moodle 2.1 ! Thanks for all the hard work!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: