Moodle
  1. Moodle
  2. MDL-28101

Bold and italics do not work with the NWIKI formatting

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7, 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 2.1.5, 2.2.2
    • Component/s: Wiki (2.x)
    • Labels:
    • Testing Instructions:
      Hide

      Note: This should be tested with patch from MDL-25883 and you should have firebug or error console for checking JS errors.

      1. Log in as Admin and turn editing on
      2. Select a course and add a wiki activity
      3. Select wiki activity and add a new NWIKI format page
      4. Click on comments tab and then click on add comment
      5. Open error console to check for javascript errors
      6. Type text and select/highlight text in comment box
      7. click on bold icon and you should not see any javascript error. Also '' should be suffixed and prefixed to selected text.
      8. Select text again and click italic icon and ''' should be suffixed and prefixed to selected text.
      Show
      Note: This should be tested with patch from MDL-25883 and you should have firebug or error console for checking JS errors. Log in as Admin and turn editing on Select a course and add a wiki activity Select wiki activity and add a new NWIKI format page Click on comments tab and then click on add comment Open error console to check for javascript errors Type text and select/highlight text in comment box click on bold icon and you should not see any javascript error. Also '' should be suffixed and prefixed to selected text. Select text again and click italic icon and ''' should be suffixed and prefixed to selected text.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
      wip-mdl-28101
    • Rank:
      17722

      Description

      Bold and italics can't be inserted by the NWIKI format rich text editor because the markup (single quotes) isn't escaped.

        Issue Links

          Activity

            People

            • Votes:
              15 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: