Moodle
  1. Moodle
  2. MDL-28121

should not use deprecated split() in webservice/lib.php

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3, 2.1
    • Fix Version/s: 2.0.4
    • Component/s: Web Services
    • Labels:
      None

      Gliffy Diagrams

        Issue Links

          Activity

          Hide
          Aparup Banerjee added a comment -

          looks great to me. thanks Dongsheng, this fixes all those notices. say no to split() !

          Show
          Aparup Banerjee added a comment - looks great to me. thanks Dongsheng, this fixes all those notices. say no to split() !
          Hide
          Sam Hemelryk added a comment -

          Thanks guys this has been integrated now.
          Apu seeing as you appear to have tested this do you mind doing it one more time to pass this test?

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Thanks guys this has been integrated now. Apu seeing as you appear to have tested this do you mind doing it one more time to pass this test? Cheers Sam
          Hide
          Aparup Banerjee added a comment -

          yup the notice for split() is gone on the plugins-> web services -> manage tokens page.

          note however this (multiplt times) (maybe my db is screwed perhaps?):

          Did you remember to make the first column something unique in your call to get_records? Duplicate value '728' found in column 'id'.
          line 803 of /lib/dml/mysqli_native_moodle_database.php: call to debugging()
          line 364 of /webservice/lib.php: call to mysqli_native_moodle_database->get_records_sql()
          line 391 of /webservice/lib.php: call to webservice->get_user_capabilities()
          line 7509 of /lib/adminlib.php: call to webservice->get_missing_capabilities_by_users()
          line 1343 of /lib/adminlib.php: call to admin_setting_managewebservicetokens->output_html()
          line 126 of /admin/settings.php: call to admin_settingpage->output_html()

          Show
          Aparup Banerjee added a comment - yup the notice for split() is gone on the plugins-> web services -> manage tokens page. note however this (multiplt times) (maybe my db is screwed perhaps?): Did you remember to make the first column something unique in your call to get_records? Duplicate value '728' found in column 'id'. line 803 of /lib/dml/mysqli_native_moodle_database.php: call to debugging() line 364 of /webservice/lib.php: call to mysqli_native_moodle_database->get_records_sql() line 391 of /webservice/lib.php: call to webservice->get_user_capabilities() line 7509 of /lib/adminlib.php: call to webservice->get_missing_capabilities_by_users() line 1343 of /lib/adminlib.php: call to admin_setting_managewebservicetokens->output_html() line 126 of /admin/settings.php: call to admin_settingpage->output_html()
          Hide
          Eloy Lafuente (stronk7) added a comment -

          This is now spread worldwide, thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - This is now spread worldwide, thanks!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: