Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28139

Validate numerical question fails

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      is_valid_answer in question/type/numerical/edit_numerical_form.php has undefined parameter.

      protected function is_valid_answer($answer, $data) {
         return $answer == '*' || $this->is_valid_number($x);
      }

        Gliffy Diagrams

          Attachments

            Activity

            rajeshtaneja Rajesh Taneja added a comment - - edited

            Got confused with MDL-27418 branch.
            Not a bug in Master, but is introduced in MDL-27418 fix.


              People

              • Assignee:
                rajeshtaneja Rajesh Taneja
                Reporter:
                rajeshtaneja Rajesh Taneja
                Participants:
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: