Moodle
  1. Moodle
  2. MDL-28144

Moodle 2.0.3 fresh instalation error 500

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.0.3
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Environment:
    • Database:
      MySQL
    • Workaround:

      I have try into two 5.3 servers and I have the same issue.

      Show
      I have try into two 5.3 servers and I have the same issue.
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      17763

      Description

      I have a problem with a fresh install of Moddle 2.0.3.

      I try with the versions 2.0.3, 2.0.3+ and the GITHUB version too.
      My server is a fresh install of CENTOS 5.6

      This is how I configure the fresh instalation:

      I download the TGZ packages (or git clone github version).
      Open my browser and I select the language of the instalation English (I try catalan too).

      I select the default dir for moodle data (outsite public folder), and the script creates and fill correctly. (next)

      I chose "imporved MYSQL" and I configure the access to mysql database. (next)

      I Accept the Copyright Notice. (next)

      The script checks my system requeriments, and all is OK. (next)

      After a few seconds, the database tables are created. (next)
      --------------------------
      Here is the 500 error, in /admin/index.php?sessionstarted=1〈=en

      This is my apache's error log:
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$libdir in /home/campus/public_html/user/editadvanced.php on line 27
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$libdir in /home/campus/public_html/user/editadvanced.php on line 28
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$dirroot in /home/campus/public_html/user/editadvanced.php on line 29
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$dirroot in /home/campus/public_html/user/editadvanced.php on line 30
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$dirroot in /home/campus/public_html/user/editadvanced.php on line 31
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined variable: PAGE in /home/campus/public_html/user/editadvanced.php on line 34
      [Thu Jun 30 10:05:36 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Fatal error: Call to a member function https_required() on a non-object in /home/campus/public_html/user/editadvanced.php on line 34

      and my "config.php" generated:

      <?php // Moodle configuration file

      unset($CFG);
      global $CFG;
      $CFG = new stdClass();

      $CFG->dbtype = 'mysqli';
      $CFG->dblibrary = 'native';
      $CFG->dbhost = 'localhost';
      $CFG->dbname = 'campus';
      $CFG->dbuser = 'campus';
      $CFG->dbpass = '***********';
      $CFG->prefix = 'mdl_';
      $CFG->dboptions = array (
      'dbpersist' => 0,
      'dbsocket' => 0,
      );

      $CFG->wwwroot = 'http://campus.myhost.local';
      $CFG->dataroot = '/home/campus/moodledata';
      $CFG->admin = 'admin';

      $CFG->directorypermissions = 0777;

      $CFG->passwordsaltmain = '***********************************';

      require_once(dirname(_FILE_) . '/lib/setup.php');

      // There is no php closing tag in this file,
      // it is intentional because it prevents trailing whitespace problems!

      ------------------------------------------------------

      I try trace the error, if in my config.php I define this variables $CFG->dirroot and $CFG->libdir, I reduce the log errors, but It doesn't work at "PAGE" definition.

      If I try to go to the index of moodle I have this log errors:

      [Thu Jun 30 10:12:31 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$dirroot in /home/campus/public_html/index.php on line 32
      [Thu Jun 30 10:12:31 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Notice: Undefined property: stdClass::$libdir in /home/campus/public_html/index.php on line 33
      [Thu Jun 30 10:12:31 2011] [warn] [client 10.84.129.146] mod_fcgid: stderr: PHP Fatal error: Call to undefined function redirect_if_major_upgrade_required() in /home/campus/public_html/index.php on line 35

      ----------------

        Issue Links

          Activity

          Xavier M. added a comment - - edited

          Finally I have found the problem: Apache APC module cache.
          In the php.ini I had this configuration line:
          apc.include_once_override = 1
          And this cause problems with php 5.3 versions. http://es2.php.net/manual/en/apc.configuration.php#96330

          The issue can be closed please.

          Michael de Raadt added a comment -

          Thanks for reporting your problem and the solution.

          At least others who have the same problem in future may benefit from your finding.

          Michael;

          Michael de Raadt added a comment -

          Closed at reporter's request.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: