Moodle
  1. Moodle
  2. MDL-28167

Fatal error: Call to undefined function coding_exception() in lib/navigationlib.php on line 1462

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2
    • Fix Version/s: 2.1.1
    • Component/s: General, Installation
    • Labels:
    • Environment:
      squeeze 2.6.37.3, php 5.3.6, mysql 5.1.57, apache 2.2.16
    • Rank:
      17871

      Description

      Upgrade process from 2.0.3+ to 2.1 was done with CLI upgrade.php script. Upgrade process end as successful. When trying to run in browser I am getting blank screen. When I turn on debug mode, I see Fatal error: Call to undefined function coding_exception() in lib/navigationlib.php on line 1462

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put it on our backlog and we'll try to get to it as soon as we can.

          In the meantime adding more information, such as screenshots, replication instructions, fix test instructions, a workaround or even a code solution, will help us and other users.

          Petr Škoda added a comment -

          I am lowering the severity because after the fix the site will display fatal error caused by invalid state in category table, this will have to be fixed manually I am afraid.

          This issue should not affect other sites.

          Thanks for the report.

          Peter Svec added a comment -

          The fix with constructor works fine. After applying there is a "Category path order is incorrect and/or there are missing categories". Categories were created in legacy versions. The solution is to manualy change the sortorder field in mdl_course_categories.

          I used this SQL query: UPDATE `mdl_course_categories` SET `sortorder` = id

          Thanks for the fix...

          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks! (21_STABLE and master)

          Eloy Lafuente (stronk7) added a comment -

          Passed based on comments from reporter, developer and nature of the fix.

          Eloy Lafuente (stronk7) added a comment -

          All this cool stuff is now part of Moodle, thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: