Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28172

Forum attachments no longer displayed in 2.1

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2
    • Fix Version/s: 2.1.1
    • Component/s: Forum
    • Labels:
    • Testing Instructions:

      1. Log in as an admin
      2. Browse to a course with a forum
      3. Edit the forum settings and ensure the "Maximum number of attachments" setting is set to two or more
      4. Start to create a new thread within the forum.
      5. In the content embed an image between some text
      6. In the file attachments section attach 2 files including one image and one other non-image file (such as a zip archive)
      7. Click "Post to forum"
      8. View the newly created thread
      9. Check that the embedded image is shown in the text where you embedded it
      10. Check that the attached image is shown at the bottom of the forum post
      11. Check that a link to download the other attached file is shown below the title of the post (to the right)

      Show
      1. Log in as an admin 2. Browse to a course with a forum 3. Edit the forum settings and ensure the "Maximum number of attachments" setting is set to two or more 4. Start to create a new thread within the forum. 5. In the content embed an image between some text 6. In the file attachments section attach 2 files including one image and one other non-image file (such as a zip archive) 7. Click "Post to forum" 8. View the newly created thread 9. Check that the embedded image is shown in the text where you embedded it 10. Check that the attached image is shown at the bottom of the forum post 11. Check that a link to download the other attached file is shown below the title of the post (to the right)
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull Master Branch:
      wip-MDL-28172-master

      Description

      Hello, after Moodle upgrade all the zip files attached to post I have made in Using Moodle forums are no more here either for posts made a few days ago and for older posts.
      I don't know if other filetypes or other users are impacted as I am only sure for my own posts.
      I am quite sure they were here on last friday.
      If necessary I can give one or 2 posts that I am sure were having zip files attached.

        Gliffy Diagrams

          Issue Links

            Activity

            jmvedrine Jean-Michel Vedrine added a comment -

            Another example of post with an attachment that is no more here :
            http://moodle.org/mod/forum/discuss.php?d=178340#p782164
            This post had a readme.txt attachment before the sunday upgrade of moodle.com to moodle 2.1

            jmvedrine Jean-Michel Vedrine added a comment -

            The files that I had attached some days ago are no more visible in the forum posts but they are still in the file picker "Recent files" so they have been uploaded correctly, but maybe I have not correctly attached these files to forum posts. This is strange because I was quite sure that I verified the file was displayed correctly in my posts ??

            aborrow Anthony Borrow added a comment -

            moving to MDL since it is in the code and not isolated to Moodle.org. Peace - Anthony

            samhemelryk Sam Hemelryk added a comment -

            This was introduced as a regression of MDL-27810

            salvetore Michael de Raadt added a comment -

            Wow. Ready for integration before I even get a chance to triage it. How efficient is that!

            jmvedrine Jean-Michel Vedrine added a comment -

            Hello Sam,
            Thanks for fixing this so quickly. Sorry to have first reported this problem as a MOODLESITE because at first I didn't had the idea to test it on my 2.1 test install!!
            I can confirm that applying the patch on my test Moodle 2.1 install fix the problem both for posts made before the fix and for posts made after. All attachments are displayed correctly.

            jmvedrine Jean-Michel Vedrine added a comment -

            Both testing and looking at the code it seems OK to me but I am certainly not an expert in forum code !!

            samhemelryk Sam Hemelryk added a comment -

            Thanks for looking at it Jean-Michel.
            No probs with creating it as an MDLSITE issue, we always check things to make sure they are in the right place and it is easy to move

            I'm putting this up for intgeration now.

            Cheers
            Sam

            tsala Helen Foster added a comment -

            Amending the issue summary, as all attachments are affected, not just zip files.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks! (21_STABLE and master).

            LOL, "overzealous check"

            salvetore Michael de Raadt added a comment -

            Test passed. No worries.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            All this cool stuff is now part of Moodle, thanks!

            jtomkinson Jordan Tomkinson added a comment -

            Applied to moodle.org


              People

              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  1/Aug/11