Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28256

/question/type/randomsamatch/db/upgradelib.php) required to run the upgrade to the new question engine.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
      None
    • Environment:
      Ubuntu 10.04 LTS 64 bit
    • Database:
      MySQL
    • Testing Instructions:
      Hide

      Download the Moodle 2.1 (1st July 2011) tgz or zip file and unpack it. Unfortunatelly /question/type/randomsamatch/db/upgradelib.php is missing ...

      Show
      Download the Moodle 2.1 (1st July 2011) tgz or zip file and unpack it. Unfortunatelly /question/type/randomsamatch/db/upgradelib.php is missing ...
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      Tried to perform a Moodle 1.9.12 upgraed to Moodle 2.1 and got the message:

      Coding error detected, it must be fixed by a programmer: Question type randomsamatch is missing important code (the file /xxxxxxxxxxxxxxxxxxxxxxxxx/moodle21/question/type/randomsamatch/db/upgradelib.php) required to run the upgrade to the new question engine.

      the file /question/type/randomsamatch/db/upgradelib.php is missing from the daily build of Moodle 2.1 done on 1st July 2011

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: