Moodle
  1. Moodle
  2. MDL-28282

Regression: groups/grouping support in SCORM 2.0 not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.2
    • Fix Version/s: 2.2.1
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:
      1. Enroll a few students (more than two ) to a course
      2. Create two separate groups and divide the students into the two groups
      3. Submit atleast one attempt to a scorm from each of the student
      4. Now go to scorm>reports>basic as admin and make sure you get no errors
      5. Now change the group from the drop down many and make sure you see the users from currently selected group only
      6. Repeat above two steps with scorm>report>interactions
      Show
      Enroll a few students (more than two ) to a course Create two separate groups and divide the students into the two groups Submit atleast one attempt to a scorm from each of the student Now go to scorm>reports>basic as admin and make sure you get no errors Now change the group from the drop down many and make sure you see the users from currently selected group only Repeat above two steps with scorm>report>interactions
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      MDL-28282-master
    • Rank:
      17909

      Description

      during my review of MDL-27523 I found groups and grouping support in the SCORM reports are broken due to the patch made in MDL-21555

      we should fix this back up.

        Issue Links

          Activity

          Brigitte Baquero added a comment -

          Any one know how can I resolve this? ... It is critical for me

          Dan Marsden added a comment -

          if it's critical enough that you have funding to pay someone to do the work - you could contract your local Moodle Partner to do the work - otherwise you'll need to wait for someone with the time to look at it and propose a fix.

          I work for the Moodle Partner Catalyst IT

          Dan Marsden added a comment -

          hehe. - just looked at your profile and saw you were from Nivel! - whoops - Hi!

          flick me an e-mail to discuss

          Dan Marsden added a comment -

          looks good, +1 to integrate - thanks Ankit!

          Ankit Agarwal added a comment -

          @ testers
          Please wait till MDL-28588 to be integrated before testing this.

          Sam Hemelryk added a comment -

          Thanks guys this has been integrated now at the same time as MDL-28588.

          Michael de Raadt added a comment -

          Test result: Passed! "Beauty, Narelle!"

          Eloy Lafuente (stronk7) added a comment -

          Yes, you did it!

          Now your code is part of the best weeklies released ever, many thanks!

          Closing, ciao


            People

            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: