Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3
    • Fix Version/s: 2.0.4, 2.1.1
    • Component/s: SCORM
    • Labels:
      None
    • Rank:
      18057

      Description

      In Moodle 2, using SCORM 2004 the "Start a new attempt" checkbox is never available.
      The problem is a variable name error in mod/scorm/locallib.php "function scorm_get_attempt_count", when the functin checks if is SCORM 1.2 or 1.3 (2004) version it check if ($scorm->version == 'scorm1_3') but the correct check is:
      if($scorm->version == 'scorm_13' || $scorm->version == 'SCORM_1.3') like in loadSCO.php

        Activity

        Dan Marsden added a comment -

        Hi Silvia,
        thanks for the report and fix.

        Dan Marsden added a comment -

        rebased against latest code.

        Sam Hemelryk added a comment -

        Thanks guys this has been integrated now.

        Cheers
        Sam

        Petr Škoda added a comment -

        I am sorry, I was unable to get that "start new attempt" prompt anywhere - I used some other packages but not luck.

        Dan Marsden added a comment -

        hmm - I'm "supposed" to be on leave so I don't think I'll have time to look at this again in time to sign it off.

        make sure you've got "forcecompleted" and "forcenewattempt" set to "no"

        if that still doesn't allow you to test this and confirm it feel free to reject it and I'll look at it again in a couple of weeks when I get back from leave.

        thanks!

        Petr Škoda added a comment -

        Hello,
        I looked at the code instead, the version change looks correct. The only potential problem is that in the codebase sometimes the scorm version comparison is cases sensitive. I suppose that may create some problems, but it would be a separate issue.

        Thanks for the report and patch, passing as tested because I did not find any problem, if the problem persists please create a new issue.

        Petr


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: