Moodle
  1. Moodle
  2. MDL-28327

Error displaying student answer in Lesson TRUE/FALSE question page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_21_STABLE
    • Rank:
      17972

      Description

      When you get the answer feedback, instead of writing your answer and then the feedback, it writes the feedback twice.
      See http://moodle.org/mod/forum/discuss.php?d=181130

        Issue Links

          Activity

          Hide
          Michael de Raadt added a comment -

          Thanks for reporting this, Joseph.

          I've asked the original reporter to elaborate more on this issue.

          Show
          Michael de Raadt added a comment - Thanks for reporting this, Joseph. I've asked the original reporter to elaborate more on this issue.
          Hide
          Joseph Rézeau added a comment -

          Hi Michael,
          I don't think there is need to elaborate on the original description which is quite adequate. In the TRUE/FALSE question type, when the student enters their answer, instead of getting both their original answer AND the feedback message, the feedback message is displayed TWICE...
          Joseph

          Show
          Joseph Rézeau added a comment - Hi Michael, I don't think there is need to elaborate on the original description which is quite adequate. In the TRUE/FALSE question type, when the student enters their answer, instead of getting both their original answer AND the feedback message, the feedback message is displayed TWICE... Joseph
          Hide
          Michael de Raadt added a comment -

          I just tried to replicate this in 2.2 and 2.3+ and it only showed the answer once.

          I followed these steps:

          1. Create a Lesson activity
          2. In the Lesson activity settings, set Display default feedback to yes
          3. Add a true/false question
          4. Preview the lesson

          Can anyone confirm that this is still a problem, and if so, what steps to follow?

          Show
          Michael de Raadt added a comment - I just tried to replicate this in 2.2 and 2.3+ and it only showed the answer once. I followed these steps: Create a Lesson activity In the Lesson activity settings, set Display default feedback to yes Add a true/false question Preview the lesson Can anyone confirm that this is still a problem, and if so, what steps to follow?
          Hide
          Joseph Rézeau added a comment -

          Cannot replicate, I expect the bug has been fixed.

          Show
          Joseph Rézeau added a comment - Cannot replicate, I expect the bug has been fixed.
          Hide
          Michael de Raadt added a comment -

          Thanks for that. I'm closing this issue.

          Show
          Michael de Raadt added a comment - Thanks for that. I'm closing this issue.

            People

            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: