Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1.2, 2.2
    • Component/s: Course, Quiz
    • Labels:
      None
    • Rank:
      17982

      Description

      Reproducing

      1. Log in as a person able to create courses
      2. Create a course
      3. Insert a quiz
      4. Create a user without enrolling them into the course
      5. Using that user's account, go to the course and click the quiz

      What do you see?

      A message saying:

      You need to enrol in this course before you can attempt this quiz

      \n\n

      \n

      What did you expect to see instead?

      A message without those three \ns


      Take a look at the attachment, which is a screenshot of the issue.

        Issue Links

          Activity

          Hide
          Petr Škoda added a comment -

          Integrated, thanks.

          Show
          Petr Škoda added a comment - Integrated, thanks.
          Hide
          Andrew Davis added a comment -

          seems to work as expected

          Show
          Andrew Davis added a comment - seems to work as expected
          Hide
          Kostas added a comment -

          Wow - this is my first bug submission here on Moodle - it is amazing how much time is needed in order to fix this bug...

          Show
          Kostas added a comment - Wow - this is my first bug submission here on Moodle - it is amazing how much time is needed in order to fix this bug...

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: