Moodle
  1. Moodle
  2. MDL-28365

lang string defined in quiz but used as it was defined in question

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2
    • Fix Version/s: 2.1.2
    • Component/s: Questions
    • Labels:
    • Testing Instructions:

      I don't know exactly how to trigger this error, Presumably trying to import a blank file into the question bank.
      Anyway, you can try that and make sure you don't get a missing string error if you like.

      Perhaps more significantly, you could look in AMOS and make sure that it has moved the string cannotread from mod_quiz to question in all lang packs, but of course, that will only happen after the weekly integration has been pushed.

      Show
      I don't know exactly how to trigger this error, Presumably trying to import a blank file into the question bank. Anyway, you can try that and make sure you don't get a missing string error if you like. Perhaps more significantly, you could look in AMOS and make sure that it has moved the string cannotread from mod_quiz to question in all lang packs, but of course, that will only happen after the weekly integration has been pushed.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      18085

      Description

      Hello Tim,
      While I work on some import formats I report all bugs I encounter even microscopics ones !
      question/format.php Line 310: echo $OUTPUT->notification(get_string('cannotread', 'question'));
      but the definition is in mod\quiz\lang\en\quiz.php
      $string['cannotread'] = 'Cannot read import file (or file is empty)';
      As I saw in another report that a general review of quiz and question lang strings is planned, I don't think you should bother to fix this one alone now. But I report it just so that it is here when the review will be done.

        Activity

        Eloy Lafuente (stronk7) added a comment -

        Integrated, thanks!

        Rajesh Taneja added a comment -

        Couldn't reproduce error by importing blank file.
        Although, tweaked code for testing and it works as expected.

        FYI:
        greped quiz code and string "cannotread" is not used

        Thanks for fixing this Tim

        Eloy Lafuente (stronk7) added a comment -

        Closing, this is now part of Moodle. Big thanks!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: