Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28406

Add Block dropdown creates duplicate block if you double click

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3, 2.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Blocks
    • Labels:

      Description

      If you add a block to a course or the front page by selecting the block item and double clicking instead of single clicking will create to two instances of the block.

      Replication instructions:

      1. Turn on Editting on Front page or a course.
      2. Select block to add and double click instead of single.
      3. Page refreshes with two of that block

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Thanks for reporting this. I can confirm this behaviour in Chrome and IE, but not FF.

              There may be other circumstances where duplicate requests are being sent.

              We could resolve this by setting a flag when click event is handled to block future events.

              andyjdavis Andrew Davis added a comment -

              Adding master branch details. I will fill out the rest after peer review.

              rajeshtaneja Rajesh Taneja added a comment -

              Looks Good to me

              andyjdavis Andrew Davis added a comment -

              Added other branches

              samhemelryk Sam Hemelryk added a comment -

              Thanks Andrew, this has been integrated now.

              nebgor Aparup Banerjee added a comment - - edited

              seems the patch here has been missed out in MOODLE_21_STABLE - sorry my bad - its there! for some weird reason somehow git fetched it this time!

              anyway this works for me!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Sent upstream and closing, many thanks!


                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Oct/11