Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3
    • Fix Version/s: 2.3
    • Component/s: Repositories
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Rank:
      17487

      Description

      Via the file repository picker, if the repository plugin supports searching, then the search link appears that opens up a modal. If the modal takes some time to appear, then the user might click on the search link a second time. If this happens several odd behaviors come forth, but the most prevalent one is that once you are done with the search modal and close it, the mask never goes away.

      Suggested solutions would be to disable the search link once it has been clicked or just ignore subsequent clicks.

        Activity

        Hide
        Dongsheng Cai added a comment -

        Thanks, Mark

        I am adding this issue to next sprint.

        Show
        Dongsheng Cai added a comment - Thanks, Mark I am adding this issue to next sprint.
        Hide
        Mark Nielsen added a comment -

        Attaching how we fixed it, I'm not 100% in love with it, but it works.

        Show
        Mark Nielsen added a comment - Attaching how we fixed it, I'm not 100% in love with it, but it works.
        Hide
        Dan Poltawski added a comment -

        Hi Mark,

        I can't reproduce this anymore on 2.3, so I think it has been fixed. Closing.

        Show
        Dan Poltawski added a comment - Hi Mark, I can't reproduce this anymore on 2.3, so I think it has been fixed. Closing.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: