Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-2850

Warning: Illegal offset type in/www.servername.edu/moodle/lib/moodlelib.php on line 769

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      The following warning:

      Warning: Illegal offset type in/www.servername.edu/moodle/lib/moodlelib.php on line 769

      pops up when replying to an email notification to a reply to another post.

      In other words, if student a post a message, if student b replies, if student c receives an email notification of student b's reply, and if student c clicks the Reply to forum link in the email notification, then the above warning pops up after student c logs in.

      Lars

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            From wild girl (helen.foster at altoncollege.ac.uk) Wednesday, 8 June 2005, 03:54 PM:

            Please check http://moodle.org/mod/forum/discuss.php?d=21215&parent=118986

            I hope this resolves the issue

            From David Jinx (djenniex at cs.mun.ca) Tuesday, 24 January 2006, 02:26 AM:

            I am still getting this error, ie.

            Warning: Illegal offset type in /var/www/moodle/lib/moodlelib.php on line 1854

            Warning: Illegal offset type in /var/www/moodle/lib/moodlelib.php on line 1929

            But it is in the calendar component, and not in the forum. Those two warning's point to the following code:

            1. if (!empty($USER->teacher[$courseid])) { // Explicitly a teacher, good

            Note: this if statement is in the isteacher function

            2. return !empty($USER->teacheredit[$courseid]);

            Note: this return statement is in the isteacheredit function

            I have already tried the is_object option detailed here: http://moodle.org/mod/forum/discuss.php?d=21215&parent=118986

            but I still receive the errors.

            Install details:

            Moodle Version: Moodle 1.5.3 (2005060230)

            Apache Version: 2.0.46

            php Version: 4.3.2

            MySQL Version: 3.23.58

            dougiamas Martin Dougiamas added a comment -

            Assigning to me temporarily because Vy-Shane no longer works for Moodle HQ.

            poltawski Dan Poltawski added a comment -

            I can't reproduce this issue and highly recomend upgrading to a recent version of moodle (the 2.0 version suggested is incorrect, this version hasn't been released yet)


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: