Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28521

Custom Menu displays URL and doesn't link correctly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Navigation
    • Labels:
      None
    • Environment:
      Ubuntu 10.10
      Linux moodle-1 2.6.35-22-server #35-Ubuntu SMP Sat Oct 16 22:02:33 UTC 2010 x86_64 GNU/Linux
    • Database:
      MySQL
    • Testing Instructions:
      Hide

      If you go to http://vle.stvincent.ac.uk/

      And use the custom menu items you will see what I mean.

      Show
      If you go to http://vle.stvincent.ac.uk/ And use the custom menu items you will see what I mean.
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      Hi Everyone,

      I'm using 2.1 (Build: 20110701) and having a go with Custom Menu's but if I use the example given, this results in the URL being shown instead of the text which can be seen on our VLE:

      http://vle.stvincent.ac.uk/

      And if you click on the link you get the following error message:

      Not Found
      The requested URL /admin/<a href= was not found on this server.

      Which is not surprising as the output is rendered as:

      <a title="Moodle community" href="<a href="http//moodle.org" class="_blanktarget">http://moodle.org</a>">Moodle community</a>

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: