Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28522

Regression: When choice set to show unanswered, additional column never shows up on teacher's 'View responses' page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 2.1.5, 2.2.2
    • Component/s: Choice
    • Labels:
    • Testing Instructions:

      Create a choice, with the setting "Show column for unanswered" set to Yes
      make sure the course has enrolled users.
      save choice.
      view the reports page - link in top right "view X responses"
      make sure a column for unanswered users is shown

      Show
      Create a choice, with the setting "Show column for unanswered" set to Yes make sure the course has enrolled users. save choice. view the reports page - link in top right "view X responses" make sure a column for unanswered users is shown
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
      master_MDL-28522

      Description

      It should appear on 'View responses' page whenever show unanswered is selected in settings. This is different to pre-2.0 behaviour which works as expected.

        Gliffy Diagrams

          Attachments

            Activity

            danmarsden Dan Marsden added a comment -

            grr - another regression from that work.... Thanks Carl I'll try to take a look this coming week.

            thanks,

            Dan

            marycooch Mary Cooch added a comment -

            I just discovered this myself - hope it can be fixed soon as it is a really useful feature for teachers!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            danmarsden Dan Marsden added a comment -

            rebased

            nebgor Aparup Banerjee added a comment -

            Hi Dan,
            looks good to integrate;

            • a regression link to the MDL here would be useful.
            • this seems to be needed for MOODLE_21_STABLE as well - just checking here while i'm inclined to cherry-pick across.
            nebgor Aparup Banerjee added a comment - - edited

            ok, it seems fine to cherry-pick (and is affecting 21) so i've jumped ahead and picked this into master, 22 as well as 21.

            EDIT: i did also amend the commit message format

            danmarsden Dan Marsden added a comment -

            looks like I missed that update to the commit message format - I've used

            area bug shortmessage

            I see it's changed sometime to

            bug area: shortmessage

            thanks.

            abgreeve Adrian Greeve added a comment -

            Tested in 2.2 and master. The additional column is now present in the responses section.
            Thanks Dan.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many thanks for your collaboration, this code has been integrated upstream and it's available in all the repositories.

            Closing, ciao


              People

              • Votes:
                2 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Mar/12