Moodle
  1. Moodle
  2. MDL-28603

Regression: SCORM 1.2 ADL test Course 1 for SCO4 Step 2 fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      Use this SCORM object (ONLY WORKS IN IE)
      https://github.com/mayankgupta/moodle_scorm_test_harness/blob/master/ADL1.2/LMSTestCourseZipPackages/LMSTestCourse01.zip?raw=true

      Enter the SCORM SCO 1 - wait for test complete message
      manually select to enter SCO 2 - wait for test complete message
      manually enter SCO 3 - wait for test complete message
      enter SCO 4 - wait for message to say first part of test complete.
      exit scorm by navigating back to Course homepage
      Enter SCORM again - make sure it takes you back to SCO 4 - NOT SCO 1

      thanks!

      Show
      Use this SCORM object (ONLY WORKS IN IE) https://github.com/mayankgupta/moodle_scorm_test_harness/blob/master/ADL1.2/LMSTestCourseZipPackages/LMSTestCourse01.zip?raw=true Enter the SCORM SCO 1 - wait for test complete message manually select to enter SCO 2 - wait for test complete message manually enter SCO 3 - wait for test complete message enter SCO 4 - wait for message to say first part of test complete. exit scorm by navigating back to Course homepage Enter SCORM again - make sure it takes you back to SCO 4 - NOT SCO 1 thanks!
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull Master Branch:
      master_MDL-28603

      Description

      When entering the package it should automatically take you to SCO 4 but instead it takes you back to SCO 1

      reporting this agains 2.2 - it definately worked in 2.0.4 so we need to see if this is in stable branches as well.

      having the new Test harness will help prevent this from occuring!

        Gliffy Diagrams

          Issue Links

            Activity

            Dan Marsden added a comment -

            this is caused by the change in MDL-26942 - should be an easy fix that I'll sort before next weeks integration review.

            Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            Aparup Banerjee added a comment - - edited

            testing: SCO #01 still says 'still testing in progress...', its been quite a few minutes now... i'm on chrome. do i need an 'ADL test suite' ?

            Dan Marsden added a comment -

            yeah - my bad sorry! - I should have stated - the ADL test packages for 1.2 only work in IE

            Eloy Lafuente (stronk7) added a comment -

            Passing based on Dan's comments and own tests:

            [22:04:36] <dan.marsden> MDL-28603 will only test in IE - but it works ok for me.

            Eloy Lafuente (stronk7) added a comment -

            Closing, this is now part of Moodle. Big thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: